Bem-vindo: Qui, 3 de Dezembro 2020, 6:03 Pesquisa avançada

Não consigo instalar um pacote .DEB no Ubuntu 11.10

Publique aqui o programa que acabou de conhecer! Questione aqui alguma opção de algum programa ou sobre a sua própria instalação!

Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Edigley Alexandre » Ter, 22 de Novembro 2011, 18:48

Estou tentando instalar um programa de extensão .DEB. Ao clicar no mesmo, é aberta a Central de Programas do Ubuntu como de costume e uma mensagem aparece: http://i679.photobucket.com/albums/vv153/edigleyg3/Amostra/Capturadetelaem2011-11-22143110.png

O pacote que estou tentando instalar está aqui: http://sourceforge.net/projects/gnofract4d/files/gnofract4d/3.14/ Minha arquitetura é i386.

Alguma dica?
@prof_edigley - Usando Ubuntu 14.04 LTS
Intel Pentuim Dual Core 2.16 GHz | 3Gib RAM | HD 250Gib
Avatar do usuário
Edigley Alexandre
 
Mensagens: 36
Registrado em: 11 Junho, 2011
Localização: Mossoró

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Luis Cardoso » Ter, 22 de Novembro 2011, 19:28

Edigley Alexandre » 22 Nov 2011, 18:48 escreveu:Estou tentando instalar um programa de extensão .DEB. Ao clicar no mesmo, é aberta a Central de Programas do Ubuntu como de costume e uma mensagem aparece: http://i679.photobucket.com/albums/vv153/edigleyg3/Amostra/Capturadetelaem2011-11-22143110.png

O pacote que estou tentando instalar está aqui: http://sourceforge.net/projects/gnofract4d/files/gnofract4d/3.14/ Minha arquitetura é i386.

Alguma dica?

Pelo que estive a ver, o pacote tem as seguintes dependências:
  • libc6 (>= 2.4)
  • libgcc1 (>= 1:4.1.1)
  • libjpeg62
  • libpng12-0 (>= 1.2.13-4)
  • libstdc++6 (>= 4.1.1)
  • python (<< 2.7)
  • python (>= 2.6)
  • python-support (>= 0.7.1)
  • libc6-dev

As dependências em vermelho são as que lhe estão a dar esse problema. Bem, o Ubuntu 11.10 tem o python 2.7.2 (pelo menos é a versão que eu tenho), e é por isso que está a dar problemas! Precisaria de ter instalado o python 2.6.x, mas também não sei como resolver esse problema :|
ImagemImagem
«Escolhe um trabalho de que gostes, e não terás que trabalhar um só dia na tua vida» - Confúcio
Avatar do usuário
Luis Cardoso
Redator
 
Mensagens: 10455
Registrado em: 26 Maio, 2011
Localização: Portugal

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Claudio Novais » Ter, 22 de Novembro 2011, 20:49

Luis Cardoso » Ter Nov 22, 2011 7:28 pm escreveu:
Edigley Alexandre » 22 Nov 2011, 18:48 escreveu:Estou tentando instalar um programa de extensão .DEB. Ao clicar no mesmo, é aberta a Central de Programas do Ubuntu como de costume e uma mensagem aparece: http://i679.photobucket.com/albums/vv153/edigleyg3/Amostra/Capturadetelaem2011-11-22143110.png

O pacote que estou tentando instalar está aqui: http://sourceforge.net/projects/gnofract4d/files/gnofract4d/3.14/ Minha arquitetura é i386.

Alguma dica?

Pelo que estive a ver, o pacote tem as seguintes dependências:
  • libc6 (>= 2.4)
  • libgcc1 (>= 1:4.1.1)
  • libjpeg62
  • libpng12-0 (>= 1.2.13-4)
  • libstdc++6 (>= 4.1.1)
  • python (<< 2.7)
  • python (>= 2.6)
  • python-support (>= 0.7.1)
  • libc6-dev

As dependências em vermelho são as que lhe estão a dar esse problema. Bem, o Ubuntu 11.10 tem o python 2.7.2 (pelo menos é a versão que eu tenho), e é por isso que está a dar problemas! Precisaria de ter instalado o python 2.6.x, mas também não sei como resolver esse problema :|

hmm o downgrade do python podia ser feito via um repositório de uma versão mais antiga do Ubuntu, no entanto, isso pode trazer muitas consequências: nomeadamente muitas das aplicações que tem neste momento instaladas deixarem de funcionar pois podem depender dessa versão ou posterior do python que tem instalado.

Nestes casos na minha opinião, só existe duas hipóteses: pedir ao programador para empacotar uma nova versão; instalar via código fonte, ou seja, compilando o programa.

Em todo o caso existe uma forma que pode solucionar o seu problema, no entanto desencorajo vivamente a utilizá-la: forçar o Ubuntu a instalar mesmo que as dependências não estejam satisfeitas. Para tal, basta fazer isto no terminal:
dpkg -i --force-depends gnofract4d_3.14-1ubuntu1_i386.deb
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Edigley Alexandre » Qua, 23 de Novembro 2011, 0:18

Claudio Novais » Ter Nov 22, 2011 5:49 pm escreveu:
Luis Cardoso » Ter Nov 22, 2011 7:28 pm escreveu:
Edigley Alexandre » 22 Nov 2011, 18:48 escreveu:Estou tentando instalar um programa de extensão .DEB. Ao clicar no mesmo, é aberta a Central de Programas do Ubuntu como de costume e uma mensagem aparece: http://i679.photobucket.com/albums/vv153/edigleyg3/Amostra/Capturadetelaem2011-11-22143110.png

O pacote que estou tentando instalar está aqui: http://sourceforge.net/projects/gnofract4d/files/gnofract4d/3.14/ Minha arquitetura é i386.

Alguma dica?

Pelo que estive a ver, o pacote tem as seguintes dependências:
  • libc6 (>= 2.4)
  • libgcc1 (>= 1:4.1.1)
  • libjpeg62
  • libpng12-0 (>= 1.2.13-4)
  • libstdc++6 (>= 4.1.1)
  • python (<< 2.7)
  • python (>= 2.6)
  • python-support (>= 0.7.1)
  • libc6-dev

As dependências em vermelho são as que lhe estão a dar esse problema. Bem, o Ubuntu 11.10 tem o python 2.7.2 (pelo menos é a versão que eu tenho), e é por isso que está a dar problemas! Precisaria de ter instalado o python 2.6.x, mas também não sei como resolver esse problema :|

hmm o downgrade do python podia ser feito via um repositório de uma versão mais antiga do Ubuntu, no entanto, isso pode trazer muitas consequências: nomeadamente muitas das aplicações que tem neste momento instaladas deixarem de funcionar pois podem depender dessa versão ou posterior do python que tem instalado.

Nestes casos na minha opinião, só existe duas hipóteses: pedir ao programador para empacotar uma nova versão; instalar via código fonte, ou seja, compilando o programa.

Em todo o caso existe uma forma que pode solucionar o seu problema, no entanto desencorajo vivamente a utilizá-la: forçar o Ubuntu a instalar mesmo que as dependências não estejam satisfeitas. Para tal, basta fazer isto no terminal:
dpkg -i --force-depends gnofract4d_3.14-1ubuntu1_i386.deb


Obrigado pela a atenção pessoal. Resolvi o problema usando um outro software semelhante ao informado aqui. Valeu!

A época que fui mais feliz com o Ubuntu, foi na versão 10.10. Quando estiver em férias, irei começar tudo do zero com ele de novo.

Abraço!
@prof_edigley - Usando Ubuntu 14.04 LTS
Intel Pentuim Dual Core 2.16 GHz | 3Gib RAM | HD 250Gib
Avatar do usuário
Edigley Alexandre
 
Mensagens: 36
Registrado em: 11 Junho, 2011
Localização: Mossoró

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Davysson Silva » Qua, 23 de Novembro 2011, 0:32

Olá Edigley Alexandre, para aquelas pessoas que não estão feliz com o ubuntu(assim como eu não estava) recomendo testar o linux mint, na versão 11.04 do ubuntu tive vários problemas e então resolvi testar o linux mint que todos falam tão bem, e estou com ele até hoje(e ubuntu 12.04 em outra partição).

Dê uma chance ao mint e você não vai se arrepender :D
Avatar do usuário
Davysson Silva
 
Mensagens: 933
Registrado em: 14 Junho, 2011

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Edigley Alexandre » Qua, 23 de Novembro 2011, 0:47

Davysson Silva » Ter Nov 22, 2011 9:32 pm escreveu:Olá Edigley Alexandre, para aquelas pessoas que não estão feliz com o ubuntu(assim como eu não estava) recomendo testar o linux mint, na versão 11.04 do ubuntu tive vários problemas e então resolvi testar o linux mint que todos falam tão bem, e estou com ele até hoje(e ubuntu 12.04 em outra partição).

Dê uma chance ao mint e você não vai se arrepender :D


Olá Davysson!

Até para escolher uma outra distro é complicado. Ouço e leio muito na web que o Mint, o Mandriva, Fedora, etc., são ótimos. Como já estava baixando o Mandriva, depois irei testar o Mint também.

Mas como você já está mais adiantado do que eu, me diz aí. Quanto aos drivers, tudo funciona ok? Reconhece multifuncionais tranquilamente (no meu caso HP)? Som, vídeo, tudo roda perfeito? Comenta aê!

Obrigado pela dica.

Abraço!
@prof_edigley - Usando Ubuntu 14.04 LTS
Intel Pentuim Dual Core 2.16 GHz | 3Gib RAM | HD 250Gib
Avatar do usuário
Edigley Alexandre
 
Mensagens: 36
Registrado em: 11 Junho, 2011
Localização: Mossoró

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Claudio Novais » Qua, 23 de Novembro 2011, 1:02

Edigley Alexandre » Qua Nov 23, 2011 12:47 am escreveu:
Davysson Silva » Ter Nov 22, 2011 9:32 pm escreveu:Olá Edigley Alexandre, para aquelas pessoas que não estão feliz com o ubuntu(assim como eu não estava) recomendo testar o linux mint, na versão 11.04 do ubuntu tive vários problemas e então resolvi testar o linux mint que todos falam tão bem, e estou com ele até hoje(e ubuntu 12.04 em outra partição).

Dê uma chance ao mint e você não vai se arrepender :D


Olá Davysson!

Até para escolher uma outra distro é complicado. Ouço e leio muito na web que o Mint, o Mandriva, Fedora, etc., são ótimos. Como já estava baixando o Mandriva, depois irei testar o Mint também.

Mas como você já está mais adiantado do que eu, me diz aí. Quanto aos drivers, tudo funciona ok? Reconhece multifuncionais tranquilamente (no meu caso HP)? Som, vídeo, tudo roda perfeito? Comenta aê!

Obrigado pela dica.

Abraço!

A grande diferença do mint para o Ubuntu é que o Mint não é nada mais que exatamente o Ubuntu com uns pacotes extra. Estes pacotes extra centram-se acima de tudo na resposta da comunidade à qual a Canonical infelizmente (ou não) não responde, dos quais se destaca: a não utilização do Unity; traz drivers proprietários (por causa disto o Mint não é legal em todos os países e é por este facto que o Ubuntu não os traz instalados); e traz os pacotes multimédia (que pelo mesmo motivo o Ubuntu não traz para estar legalizado em todos os países), nomeadamente pacotes para ler formatos proprietários de vídeo e som.

De uma forma geral a diferença é esta. Claro que traz outras, mas pouco mais diferente é! (nomeadamente não traz o centro de software do Ubuntu que é das aplicações mais lentas que conheço, traz um menu todo estilizado etc)
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Davysson Silva » Qua, 23 de Novembro 2011, 1:04

Edigley Alexandre » Qua Nov 23, 2011 12:47 am escreveu:
Davysson Silva » Ter Nov 22, 2011 9:32 pm escreveu:Olá Edigley Alexandre, para aquelas pessoas que não estão feliz com o ubuntu(assim como eu não estava) recomendo testar o linux mint, na versão 11.04 do ubuntu tive vários problemas e então resolvi testar o linux mint que todos falam tão bem, e estou com ele até hoje(e ubuntu 12.04 em outra partição).

Dê uma chance ao mint e você não vai se arrepender :D


Olá Davysson!

Até para escolher uma outra distro é complicado. Ouço e leio muito na web que o Mint, o Mandriva, Fedora, etc., são ótimos. Como já estava baixando o Mandriva, depois irei testar o Mint também.

Mas como você já está mais adiantado do que eu, me diz aí. Quanto aos drivers, tudo funciona ok? Reconhece multifuncionais tranquilamente (no meu caso HP)? Som, vídeo, tudo roda perfeito? Comenta aê!

Obrigado pela dica.

Abraço!


No meu computador ele sempre reconheceu os drives( minha multifuncional também é HP), por ele ser baseado no ubuntu tem as mesmas características só que muito mais estável, o motivo disto é que o principal causador de bugs do ubuntu atualmente é o unity, que não está no mint.

Imagem

Assim como você também pensei em testar fedora, archlinux entre outros. Preferi o mint por ser baseado no ubuntu e ser compatível com todos os programas dele, além de alguns próprios( como a central de programas que é muito mais rápida ).

Outra coisa que me agrada é que ele tem versão DVD que já vem com todos os codecs de áudio e vídeo. java, etc...

Enfim o mint se encaixa nas minhas necessidades, isso é linux teste e se não gostar teste outra até encontrar a que se enquadra melhor com você. :yeah:
Avatar do usuário
Davysson Silva
 
Mensagens: 933
Registrado em: 14 Junho, 2011

Re: Não consigo instalar um pacote .DEB no Ubuntu 11.10

Mensagempor Edigley Alexandre » Qua, 23 de Novembro 2011, 1:18

Claudio Novais » Ter Nov 22, 2011 10:02 pm escreveu:
Edigley Alexandre » Qua Nov 23, 2011 12:47 am escreveu:
Davysson Silva » Ter Nov 22, 2011 9:32 pm escreveu:Olá Edigley Alexandre, para aquelas pessoas que não estão feliz com o ubuntu(assim como eu não estava) recomendo testar o linux mint, na versão 11.04 do ubuntu tive vários problemas e então resolvi testar o linux mint que todos falam tão bem, e estou com ele até hoje(e ubuntu 12.04 em outra partição).

Dê uma chance ao mint e você não vai se arrepender :D


Olá Davysson!

Até para escolher uma outra distro é complicado. Ouço e leio muito na web que o Mint, o Mandriva, Fedora, etc., são ótimos. Como já estava baixando o Mandriva, depois irei testar o Mint também.

Mas como você já está mais adiantado do que eu, me diz aí. Quanto aos drivers, tudo funciona ok? Reconhece multifuncionais tranquilamente (no meu caso HP)? Som, vídeo, tudo roda perfeito? Comenta aê!

Obrigado pela dica.

Abraço!

A grande diferença do mint para o Ubuntu é que o Mint não é nada mais que exatamente o Ubuntu com uns pacotes extra. Estes pacotes extra centram-se acima de tudo na resposta da comunidade à qual a Canonical infelizmente (ou não) não responde, dos quais se destaca: a não utilização do Unity; traz drivers proprietários (por causa disto o Mint não é legal em todos os países e é por este facto que o Ubuntu não os traz instalados); e traz os pacotes multimédia (que pelo mesmo motivo o Ubuntu não traz para estar legalizado em todos os países), nomeadamente pacotes para ler formatos proprietários de vídeo e som.

De uma forma geral a diferença é esta. Claro que traz outras, mas pouco mais diferente é! (nomeadamente não traz o centro de software do Ubuntu que é das aplicações mais lentas que conheço, traz um menu todo estilizado etc)


Agora fiquei numa sinuca sem saída... o.0
Obrigado Cláudio pelos esclarecimentos.
@prof_edigley - Usando Ubuntu 14.04 LTS
Intel Pentuim Dual Core 2.16 GHz | 3Gib RAM | HD 250Gib
Avatar do usuário
Edigley Alexandre
 
Mensagens: 36
Registrado em: 11 Junho, 2011
Localização: Mossoró


Voltar para Programas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 7 visitantes

cron