Bem-vindo: Sex, 15 de Janeiro 2021, 15:38 Pesquisa avançada

[RESOLVIDO] Tem como instalar o HPLIP no elementary OS Luna?

Publique aqui o programa que acabou de conhecer! Questione aqui alguma opção de algum programa ou sobre a sua própria instalação!

[RESOLVIDO] Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Ron Alon » Qua, 21 de Novembro 2012, 12:34

Oi, pessoal!

A minha dúvida é a seguinte: eu uso uma impressora HP, e quero utilizá-la sem fios (e ela tem o suporte e, inclusive, a utilizava assim no Ubuntu 12.04).
Agora estou usando o elementary OS Luna, que é baseado no 12.04, porém eu não consigo instalar o hplip, o gerenciador de impressoras HP.

Vejam só:

error: Auto installation is not supported for 'unknown' distro so all dependencies may not be installed.
Please install manually as mentioned in 'http://hplipopensource.com/hplip-web/install/manual/index.html' web-site

Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*):


Se eu uso o n, ele simplesmente sai da instalação! Mas dou y.

Ele pede para escolher entre instalação automática ou customizada. Já havia tentado a automática e fui tentar agora a customizada e chegaram no mesmo erro:

INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
warning: There are 7 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: This installer cannot install 'gcc' for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.


Bom, poderia ser problema de falar este gcc. Porém:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
gcc já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 18 não atualizados.


Será que o problema é a distro reconhecida não ser uma do Ubuntu 12.04? Ele mostra até compatibilidade com o Mint - mas não com o elementary.

Alguém sabe um jeito de burlar isto?

Eu sei que eu que deveria trazer uma solução para isto, mas e agora? :lol:
Editado pela última vez por Ron Alon em Qui, 22 de Novembro 2012, 14:44, em um total de 1 vez.
Avatar do usuário
Ron Alon
Redator Geekzinho
 
Mensagens: 4145
Registrado em: 27 Julho, 2011
Localização: São Vicente-SP / Brasil

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Luis Cardoso » Qua, 21 de Novembro 2012, 12:39

Experimente instalar o seguinte pacote:
sudo apt-get install -y build-essential


E já agora, qual é a saída do seguinte comando?
lsb_release -a
ImagemImagem
«Escolhe um trabalho de que gostes, e não terás que trabalhar um só dia na tua vida» - Confúcio
Avatar do usuário
Luis Cardoso
Redator
 
Mensagens: 10455
Registrado em: 26 Maio, 2011
Localização: Portugal

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Ron Alon » Qua, 21 de Novembro 2012, 12:42

Luis Cardoso (21-11-2012, 11:39) escreveu:E já agora, qual é a saída do seguinte comando?
lsb_release -a



Esta:

No LSB modules are available.
Distributor ID: elementary OS
Description: elementary OS Luna
Release: 0.2
Codename: luna
Suite: precise
Avatar do usuário
Ron Alon
Redator Geekzinho
 
Mensagens: 4145
Registrado em: 27 Julho, 2011
Localização: São Vicente-SP / Brasil

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Ron Alon » Qua, 21 de Novembro 2012, 12:46

Instalei o pacote mas nada mudou. :(
Avatar do usuário
Ron Alon
Redator Geekzinho
 
Mensagens: 4145
Registrado em: 27 Julho, 2011
Localização: São Vicente-SP / Brasil

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Luis Cardoso » Qua, 21 de Novembro 2012, 12:47

Ron Alon (21-11-2012, 11:42) escreveu:
Luis Cardoso (21-11-2012, 11:39) escreveu:E já agora, qual é a saída do seguinte comando?
lsb_release -a



Esta:

No LSB modules are available.
Distributor ID: elementary OS
Description: elementary OS Luna
Release: 0.2
Codename: luna
Suite: precise

o mais provável é que o hplip esteja a ver do seguinte resultado:
luis@ubuntued:~$ lsb_release -cs
precise

Mas como está a ver luna... E depois há ali a questão do elementary OS na distribuição...
ImagemImagem
«Escolhe um trabalho de que gostes, e não terás que trabalhar um só dia na tua vida» - Confúcio
Avatar do usuário
Luis Cardoso
Redator
 
Mensagens: 10455
Registrado em: 26 Maio, 2011
Localização: Portugal

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Ron Alon » Qua, 21 de Novembro 2012, 12:50

Luis Cardoso (21-11-2012, 11:47) escreveu:o mais provável é que o hplip esteja a ver do seguinte resultado:
luis@ubuntued:~$ lsb_release -cs
precise

Mas como está a ver luna... E depois há ali a questão do elementary OS na distribuição...


Não duvido disto. Que chato! Remasters/forks tem este problema. ¬¬ Deveriam ser todas compatíveis entre si!
Avatar do usuário
Ron Alon
Redator Geekzinho
 
Mensagens: 4145
Registrado em: 27 Julho, 2011
Localização: São Vicente-SP / Brasil

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Luis Cardoso » Qua, 21 de Novembro 2012, 12:50

Ron Alon (21-11-2012, 11:46) escreveu:Instalei o pacote mas nada mudou. :(

E seguir a indicação dada pelo instalador e fazer assim:
Instalação Manual
ImagemImagem
«Escolhe um trabalho de que gostes, e não terás que trabalhar um só dia na tua vida» - Confúcio
Avatar do usuário
Luis Cardoso
Redator
 
Mensagens: 10455
Registrado em: 26 Maio, 2011
Localização: Portugal

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Luis Cardoso » Qua, 21 de Novembro 2012, 12:52

Luis Cardoso (21-11-2012, 11:50) escreveu:
Ron Alon (21-11-2012, 11:46) escreveu:Instalei o pacote mas nada mudou. :(

E seguir a indicação dada pelo instalador e fazer assim:
Instalação Manual

Ou então veja este procedimento:
Manual Build and Install Instructions for Ubuntu
ImagemImagem
«Escolhe um trabalho de que gostes, e não terás que trabalhar um só dia na tua vida» - Confúcio
Avatar do usuário
Luis Cardoso
Redator
 
Mensagens: 10455
Registrado em: 26 Maio, 2011
Localização: Portugal

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Ron Alon » Qua, 21 de Novembro 2012, 13:11

Perguntei sobre isto no launchpad. Vamos ver!
Avatar do usuário
Ron Alon
Redator Geekzinho
 
Mensagens: 4145
Registrado em: 27 Julho, 2011
Localização: São Vicente-SP / Brasil

Re: Tem como instalar o HPLIP no elementary OS Luna?

Mensagempor Claudio Novais » Qui, 22 de Novembro 2012, 14:07

Antes de mais: eu não tenho a certeza disto que vou dizer, é só algo teórico.

Provavelmente o HPlip procura saber qual a versão do sistema para saber de que maneira instalar os drivers. Uma vez que os remasters têm este problema de alterarem o nome e depois os softwares ao fazerem estas verificações falharem, e uma vez que os remasters pouco mais são que instalações de pacotes extra sobre um Ubuntu original, então talvez possamos enganar temporariamente os programas aquando da instalação.

Atenção, eu disse temporariamente precisamente para evitar que ocorram posteriores problemas. Assim recomendo que a alteração seja temporária, apenas durante a instalação do HPlip.

Basicamente será editar o seguinte ficheiro pondo os valores originais do Ubuntu ao qual o ElementaryOS se baseia:
  • /etc/lsb-release
Assim, abra esse ficheiro e edite-o para as informações do Ubuntu. No caso do elementaryOS como ele é um Ubuntu 12.04, as informações que deverão constar são as seguintes:
Código: Selecionar todos
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"

Para editar o ficheiro:
sudo gedit /etc/lsb-release

Não se esqueça de fazer backup antes de editar e depois de instalar o HPlip volte a pôr como estava antes pois o ElementaryOS pode precisar dessa informação.
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011

Próximo

Voltar para Programas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante