Bem-vindo: Ter, 15 de Outubro 2019, 15:39 Pesquisa avançada

Firefox 10 melhora compatibilidade com extensões antigas

Secção dedicada aos browsers: Firefox, Google Chrome, Chromium, Opera e até aos demais desconhecidos. Apresentam-se novidades, extensões, questões, tweaks, tudo sobre estes navegadores! Sendo válido para todas as plataformas, Linux, MacOS e Windows!

Firefox 10 melhora compatibilidade com extensões antigas

Mensagempor Luciano Fernandes » Qua, 1 de Fevereiro 2012, 2:34

Boa noite! Desejo que todas(os) estejam bem :!: :OK:


A Mozilla liberou hoje a atualização para o Firefox 10. Entre melhorias leves aqui e ali o grande destaque mesmo para os usuários comuns é a compatibilidade com extensões antigas, um problema comum no Firefox.


Tradicionalmente, a cada lançamento muitas extensões apresentavam alguma incompatibilidade e deixavam de funcionar. Especialmente aquelas distribuídas fora do site de extensões da Mozilla - o que corresponde a cerca de 75% dos add-ons, segundo a própria.

Com o Firefox 10 agora qualquer extensão que funcionava no Firefox 4 deve funcionar nele também. Exceto em alguns raros casos em que a compatibilidade fica mesmo prejudicada por alterações nas APIs ou outras questões técnicas. Em vez de aplicar um bloqueio artificial que proíbe a instalação das extensões apenas por ter trocado de versão, agora as extensões incompatíveis serão bloqueadas uma a uma. Isso faz parte do plano de atualizações silenciosas para o Firefox, que será concluído nos próximos meses - algo similar ao que ocorre com o Chrome.

Essa versão também oferece melhores ferramentas para webmasters e desenvolvedores, fornecendo maior controle de edição dos elementos da página em tempo real para análise do código:

Algumas melhorias foram implementadas nos elementos de composição da página, como anti-aliasing para WebGL, transformadores para o CSS3 3D, API de tela cheia, entre outras coisas detalhadas nesta página.

Ah, e uma leve mudança estética: o botão "avançar" agora só aparece quando for necessário, deixando a tela do navegador mais limpa.

Como anunciado, esta versão 10 do Firefox será suportada por quase um ano, cumprindo o objetivo da edição "Extended Support Release". Sendo assim, será seguro mantê-la por mais tempo resistindo aos lançamentos futuros no decorrer deste ano, evitando as tão temidas atualizações em ambientes corporativos. Note que o instalador da edição ESR é separado: baixe-o por aqui (os links estão no final desta página, que por equanto está apenas em inglês). O Firefox 10 "comum" será atualizado para o 11 em breve, mas o ESR será mantido ao longo do ano apenas com correções importantes, sem novos recursos.

A atualização para o Firefox 10 pode ser feita na tela "Sobre", ou baixando o instalador diretamente em:

http://www.mozilla.org/pt-BR/firefox/new/

Se quiser os links diretos: Windows - Mac - Linux

Tem site por aí dizendo que o Firefox 10 está em "beta", talvez porque na hora da publicação a página dele ainda não tinha sido atualizada. Aqui ele foi atualizado no canal "release", e como consta nas notas de lançamento, não é beta.


Correlativos: Mozilla e Firefox


Caso tenha gostado do post, por favor, prestigie a fonte para este e outros assuntos afins :!: :obrigado: o :ubuntued: agradece sua preferência, volte sempre! ;)


:arrow: ORIGEM CRIACIONAL: HARDWARE



Vivamos a LIBERDADE com total DIGNIDADE!
"[...] For we can do nothing against the TRUTH, but for the TRUTH..."
Avatar do usuário
Luciano Fernandes
Nuntius Express
 
Mensagens: 1070
Registrado em: 26 Junho, 2011
Localização: Rio de Janeiro, Brazil.

Re: Firefox 10 melhora compatibilidade com extensões antigas

Mensagempor Davysson Silva » Qua, 1 de Fevereiro 2012, 2:53

Pra min uma das melhorias mais importantes. Era bastante irritante a questão de compatibilidade :\
Avatar do usuário
Davysson Silva
 
Mensagens: 933
Registrado em: 14 Junho, 2011

Re: Firefox 10 melhora compatibilidade com extensões antigas

Mensagempor Claudio Novais » Sáb, 4 de Fevereiro 2012, 16:47

Exatamente, a compatibilidade sempre foi o Calcanhar de Aquiles do Firefox! Nunca se podia atualizar logo para as versões mais atuais porque corria-se sempre o risco de os programadores das extensões não terem atualizado "a compatibilidade", que normalmente era apenas um número na configuração (algo equivalente às dependências dos pacotes do Ubuntu.)
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011


Tópicos Similares:

Voltar para Browsers - Navegadores de Internet

Quem está online

Usuários navegando neste fórum: MarkBog e 2 visitantes

cron