Bem-vindo: Sex, 18 de Agosto 2017, 19:10 Pesquisa avançada

Ubuntu 12.04 Precise Pangolin – Resolvendo problema com Java

Tem um artigo interessante e importante para a comunidade? Quer apresentar um software que acabou de conhecer? Ou até um software ou script seu? Então veja nesta secção como o redigir corretamente para publicar artigos no Blog do Ubuntued!

Ubuntu 12.04 Precise Pangolin – Resolvendo problema com Java

Mensagempor novacriatura » Sex, 2 de Março 2012, 5:40

Ubuntu 12.04 Precise Pangolin – Resolvendo problema com Java

Instalar o Oracle Java JDK 7 no Ubuntu através do PPA
Este pacote fornece Oracle Java JDK 7 (que inclui o JRE eo plugin para o navegador Java). No entanto, você não só pode instalar o Oracle JRE – o PPA prevê apenas o total da Oracle JDK7 pacote.

Para adicionar o nosso PPA e instalar o Oracle Java (JDK) 7 no Ubuntu, use os comandos abaixo:

sudo add-apt-repository ppa:webupd8team/java && sudo apt-get update

sudo apt-get install -y oracle-jdk7-installer


http://www.novacritura.org

Créditos / Artigo Original : http://www.webupd8.org/2011/09/how-to-i ... dk-in.html

novacriatura
 
Mensagens: 2
Registrado em: 22 Dezembro, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Claudio Novais » Qua, 25 de Abril 2012, 14:46

Olá novacriatura,

Não tinha reparado neste seu tópico! obrigado por esta partilha! Vai ajudar quem procura solução para este problema criado pela Oracle!
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Qua, 25 de Abril 2012, 15:38

Espero também que este ppa resolva situações semelhantes à que me ocorreu há alguns dias atrás.

Há já alguns anos que por esta altura envio a Declaração eletrónica de IRS através do portal das Finanças e para surpresa minha não estava a conseguir a abertura das páginas dos modelos a preencher. Para tal era necessário o Java instalado.
Ele estava instalado, mas verifiquei que os elementos que o compunham não estavam a dar resposta e antes que não conseguisse resolver esta questão antes do limite do prazo de entrega, aproveitei e enviei através do meu seven, operação esta que decorreu normalmente tal como em anos anteriores no Ubuntu! :|
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor marcos.vargens » Dom, 29 de Abril 2012, 4:37

Existe um problema com essas versões do java e os browsers. No linux, faço manualmente o trabalho de instalar o java e incluir o plugin do mesmo no browser. A maior confusão fica por conta do Windows mesmo e muita gente não entende o motivo.

Os browsers do Windows 64 bits, são 32 bits. Portanto não adianta instalar a versão 64 bits do plugin do java. Ela não é compatível com ele. Você pode instalar a jre para usar programas que rodam no computador, mas para o browser, obrigatoriamente tem que ser 32 bits.

No linux acredito que possa acontecer o contrário. Os browsers para linux 64 bits, são realmente 64 bits. Se você instalar uma versão 32 bits do java, o plugin pode não funcionar.
Existe uma página que testa se o java está instalado e rodando. Infelizmente ela tem um bug, pois mesmo tendo a versão 7 do java, ela recomenda instalar a versão 6. Mas é ideal para saber se o plugin do java está rodando de maneira correta. Segue o link:
http://www.java.com/pt_BR/download/inst ... =jre&try=1

marcos.vargens
 
Mensagens: 603
Registrado em: 12 Julho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Alan Alves » Dom, 29 de Abril 2012, 15:47

Valeu, valeu perfeito.

Avatar do usuário
Alan Alves
 
Mensagens: 6
Registrado em: 28 Outubro, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor deni » Ter, 1 de Maio 2012, 5:31

Instalei o Java no 12.04 mas tenho em outro hd o Ubuntu 10.04 e com sua indicação consegui instalar nele também e fazer funcionar.Parabéns pelo artigo.

deni
 
Mensagens: 1
Registrado em: 01 Maio, 2012

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Ter, 1 de Maio 2012, 12:47

Acima tinha referido que tinha instalado a versão 7 via ppa; bom, como nunca é demais observar opiniões dos mais entendidos em assuntos que não dominamos, decidi removê-lo, ainda que não chegasse a fazer o teste a uma página com exigência do Java com as características da que mencionei, mas com base em alguns entraves ocorridos em plugins diversos com o pacote Medibuntu que havia instalado anteriormente, que também inclui o Java e o qual removi, optei por recorrer ao método que sempre utilizei e do qual no geral não tenho tido razão de queixa e que é o pacote Restricted-extras para Ubuntu. Estando este instalado, verifiquei o comportamento da versão do Java incluída através do teste no link deixado pelo marcos.vargens e foi detetada a falta do Java adequado.
Imediatamente o Firefox mostrou as duas opções, uma com a versão 6 e outra com a 7 e optei por agora apenas instalar a 6, entretanto a indicação (abaixo) que recebi foi a falta da 6 mais recente, não sei se ainda assim neste caso a deva instalar ou aguardar mais um pouco! :|

Verificando a versão do Java
Uma versão mais recente do Java está disponível

Clique no botão de download para obter o Java recomendado para o seu computador.
Sua versão do Java: Version 6 Update 24

Fazer o download gratuito do software Java
Version 6 Update 31
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Ter, 1 de Maio 2012, 14:02

Boas José, devido às inúmeras vulnerabilidades encontradas recentemente no Java, das quais resultou este último update, o 6.0-31, é aconselhável o quanto antes fazeres a instalação da versão mais recente!!!

Segue este tutorial em Português (o mesmo processo que utilizo cada vez que actualizo o meu Java!), que na minha opinião não é complicado.

http://espacoliberdade.blog.br/blog/debian/como-instalar-java-debian/#more-4707

Utilizando a versão mais recente descarregada do site oficial.

Deixo aqui o link directo caso queiras:

Versão para 32 bits:

http://javadl.sun.com/webapps/download/AutoDL?BundleId=59621

Versão para 64 bits:

http://javadl.sun.com/webapps/download/AutoDL?BundleId=59623

No tutorial, a instalação é feita na pasta "jvm" dentro de /usr/lib.
Se ainda não existir no teu sistema (meu caso, visto que não tinha nenhum Java instalado), terás de criá-la.
Para tal, no terminal:

cd /usr/lib


e depois:

sudo mkdir jvm


Depois é só seguires o tutorial.

Alguma dúvida, "posta" aqui.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Qua, 2 de Maio 2012, 2:20

Obrigado Miguel. Portanto significa que a 6-31 como a mais recente, é aconselhável instalar!
Para além deste método de instalação, se eu usar o mesmo que usei para instalar a 6-24, também é um bom método ou terei mesmo que seguir este tutorial?
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Qua, 2 de Maio 2012, 3:45

José Craveiro » Qua Mai 02, 2012 2:20 am escreveu:Obrigado Miguel. Portanto significa que a 6-31 como a mais recente, é aconselhável instalar!
Para além deste método de instalação, se eu usar o mesmo que usei para instalar a 6-24, também é um bom método ou terei mesmo que seguir este tutorial?


Bem José, começo por dizer que todo este procedimento destina-se a quem, como eu, prefere o Java da Oracle instalado no Ubuntu.
Esta preferência tem unicamente como justificação, o facto de ter maior compatibilidade como o "universo" Java do que a versão Open JDK.

Visto isto, como sabes, a última versão do Java oficial não está disponível nos repositórios do Ubuntu e a única que se encontra disponível nos mesmos é a versão 6.0-24 que tem mais "buracos" que um queijo suíço!!! :lol:

Através do Launchpad (PPA), a única versão que se encontra disponível é a 7, mas penso que já falámos sobre ela.
No entanto, lá mais para o meio do ano, já deve estar disponível como última versão estável.

Como tal, a única maneira de instalar (para já!) a última versão estável do Java oficial é manualmente.
Aconselhei o procedimento referido, pois é o que utilizo desde a versão 10.10.
Penso que não é complicado e RESULTA!

Para terminar, é evidente que ter o Java instalado não é obrigatório, mas dá jeito.
E podemos sempre optar pela Open JDK, mas existem ainda alguns problemas (como já referi) de compatibilidade com certos sites, nomeadamente, netbanking e irs.
Também podemos seguir o tutorial do início deste "post" e instalar a versão 7, mas, como também já referi, acedendo ao site oficial da Oracle/Java, eles explicam que esta versão ainda está em fase de testes e poderá, com tal (e como já é infelizmente costume!) ter problemas de estabilidade e segurança.

É, minha opinião, que, para quem quer ter o Java oficial instalado, deve recorrer sempre à última versão estável.

Deixo agora ao teu critério e de cada um, a decisão final.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Próximo

Tópicos Similares:

Voltar para Publique artigos no Blog Ubuntued!

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante