Bem-vindo: Ter, 21 de Novembro 2017, 5:22 Pesquisa avançada

[+ ou - RESOLVIDO] Brilho some e não volta no elementaryOS

Esta secção é dedicada a todas as distribuições de Linux, por exemplo, Gentoo, Ubuntu Ultimate Edition, Mint, Kubuntu etc. Poderá apresentar distribuições, questionar sobre problemas e até apresentar tutoriais!

Re: Brilho some e não volta no elementaryOS

Mensagempor rodrigo_sabbat » Ter, 3 de Dezembro 2013, 4:40

O pior é que não tem nada do tipo assim lá.
Na minha BIOS tem apenas uma aba chamada "Info" e tem o nome, modelo do PC, memória, etc; informações. Uma aba chamada "Boot" pra configurar a ordem do boot. Uma aba chamada "Security" onde se coloca senha de bloqueio no note e etc. Uma aba "UEFI" onde configura-se a forma de boot (UEFI ou legacy). E uma aba chamada "Exit & Save" onde tem opções pra salvar e sair ou sair sem salvar.

...

E agora...? :S
Imagem
Oi, eu sou o Sabbat!
Sou novo no fórum e no mundo do Linux Ubuntu.
Pra quem não me conhece, minha apresentação está aqui.
Imagem
Avatar do usuário
rodrigo_sabbat
 
Mensagens: 144
Registrado em: 01 Outubro, 2012
Localização: Brasil

Re: Brilho some e não volta no elementaryOS

Mensagempor Miguel Fonseca » Ter, 3 de Dezembro 2013, 21:19

Bem, faz o seguinte, no terminal, executa este comando:

sudo pm-suspend --quirk-dpms-on


ENTER, coloca a tua password e ENTER.

Experimenta hibernar e depois acordá-lo e vê se o problema continua.

Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Brilho some e não volta no elementaryOS

Mensagempor rodrigo_sabbat » Sáb, 7 de Dezembro 2013, 16:20

Desculpe a demora a responder. Foi uma semana um pouco cheia pra mim.
Ok, voltando ao que interessa...

Executei o comando que tu me disseste e o notebook hibernou. Mais do que esperado.
Quando voltei a ligá-lo, o brilho não sumiu. Em compensação a tela ficou congelada. Congelada mesmo. Estava do jeito que ela tinha ficado a hora que eu executei o comando, mas nada se mexia. Não adiantava mexer em teclado nem mouse. :/

Idéias?
Imagem
Oi, eu sou o Sabbat!
Sou novo no fórum e no mundo do Linux Ubuntu.
Pra quem não me conhece, minha apresentação está aqui.
Imagem
Avatar do usuário
rodrigo_sabbat
 
Mensagens: 144
Registrado em: 01 Outubro, 2012
Localização: Brasil

Re: Brilho some e não volta no elementaryOS

Mensagempor Miguel Fonseca » Dom, 8 de Dezembro 2013, 14:19

Boas Rodrigo, vamos tentar adicionar um parâmetro ao kernel para ver se resulta!

O parãmetro é este:

Código: Selecionar todos
acpi_sleep=nonvs


Não adicionaes já este parâmetro definitivamente ao kernel, vais só adicioná-lo no próximo boot!

Se resultar, então passa adefinitivo.

Para saberes como fazer isto, lê este artigo (vais ver que é fácil!) e executa primeiro, o provisório e, se vires que resulta, então executa o procedimento para torná-lo permanente.

https://wiki.ubuntu.com/Kernel/KernelBootParameters

Depois, fá-lo hibernar, "acorda-o" e vê se resolveu o problema.

Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Brilho some e não volta no elementaryOS

Mensagempor rodrigo_sabbat » Seg, 9 de Dezembro 2013, 17:13

Miguel, acho que surtiu efeito! Digo, em relação ao sumiço do brilho quando hiberna. Mas, quando eu mando hibernar. Não consegui testar isso quando ele hiberna sozinho. Aparentemente ele não quis hibernar sozinho. Eu tinha desativado e reativei, mas parece não ter funcionado. Acho que ele não está hibernando sozinho. Minha noção de tempo é meio perdida, mas vou tentar configurar ele para hibernar em 5 minutos e esperar os 5 minutos olhando pra tela. Achei estranho isso. Mas, talvez não seja mais do que isso: eu perdendo a noção do tempo. Apareço em breve com a resposta definitiva, mas, aparentemente funcionou.

Obrigado por toda a ajuda, Miguel! :yeah:
Imagem
Oi, eu sou o Sabbat!
Sou novo no fórum e no mundo do Linux Ubuntu.
Pra quem não me conhece, minha apresentação está aqui.
Imagem
Avatar do usuário
rodrigo_sabbat
 
Mensagens: 144
Registrado em: 01 Outubro, 2012
Localização: Brasil

Re: Brilho some e não volta no elementaryOS

Mensagempor Miguel Fonseca » Seg, 9 de Dezembro 2013, 20:36

Boas Rodrigo, então se realmente tiver tudo a funcionar, é uma boa noticia!

Mas, nesse caso, edita o teu primeiro post e adiciona a palavra "Resolvido" para que outros utilizadores possam beneficiar de uma possível solução para um problema idêntico.

Caso ainda não esteja tudo a 100%, posta aqui e tentaremos resolvê-lo!

Hasta.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Brilho some e não volta no elementaryOS

Mensagempor rodrigo_sabbat » Ter, 10 de Dezembro 2013, 3:35

Olá Miguel! Tudo bem?

Então, sobre o problema do brilho, começo a notar que o problema não tem a ver com hibernar ou suspender o notebook. O problema é com o recurso "Desligar a tela quando inativo". Após ele desligar a tela, eu mexo o mouse (ou no touchpad) e de fato a tela reativa, porém com o brilho no zero, sendo quase impossível de enxergar algo. Um dos métodos que tenho é colocar a tela contra a luz para ir no "Brightness Indicator" que tenho, que fica na barra superior, e selecionar um nível aceitável de brilho.

No fim das contas, acho que fiz você caminhar em círculos. :S
Por agora, a solução é desativar o desligamento da tela, já que é esse o problema. O ruim é que, se tratando de um notebook, esse recurso pouparia bateria. :\

Não sei se ainda teremos como resolver isso ou se eu deixo assim como está...

Em todo o caso, obrigado por toda a ajuda até agora, Miguel! :yeah:
Imagem
Oi, eu sou o Sabbat!
Sou novo no fórum e no mundo do Linux Ubuntu.
Pra quem não me conhece, minha apresentação está aqui.
Imagem
Avatar do usuário
rodrigo_sabbat
 
Mensagens: 144
Registrado em: 01 Outubro, 2012
Localização: Brasil

Re: [+ ou - RESOLVIDO] Brilho some e não volta no elementary

Mensagempor Hmm » Sex, 26 de Dezembro 2014, 2:51

Instalei o elementary e está funcionando perfeitamente. O que está me incomodando é que o brilho da tela está no máximo, e mesmo eu diminuindo-o pelas teclas fn, apesar da barra do nível de brilho diminuir, a tela continua do mesmo jeito, já tentei pelas configurações do sistema e nada. Alguém tem alguma idéia? Obrigado

Hmm
 
Mensagens: 4
Registrado em: 26 Dezembro, 2014

Re: [+ ou - RESOLVIDO] Brilho some e não volta no elementary

Mensagempor Luis Cardoso » Sex, 26 de Dezembro 2014, 16:49

Hmm (26-12-2014, 1:51) escreveu:Instalei o elementary e está funcionando perfeitamente. O que está me incomodando é que o brilho da tela está no máximo, e mesmo eu diminuindo-o pelas teclas fn, apesar da barra do nível de brilho diminuir, a tela continua do mesmo jeito, já tentei pelas configurações do sistema e nada. Alguém tem alguma idéia? Obrigado

Antes de instalar o elementary OS experimentou outra distro e apresentava o mesmo problema? Caso não tenha testado com outra distro, pode ser um problema de driver específico (há casos assim...) para controlar a iluminação, mas também pode ser um bug da actual versão que esteja a afectar apenas determinado hardware... Mas com pouca informação, é um pouco inconclusivo...
ImagemImagem
«Escolhe um trabalho de que gostes, e não terás que trabalhar um só dia na tua vida» - Confúcio
Avatar do usuário
Luis Cardoso
Redator
 
Mensagens: 10455
Registrado em: 26 Maio, 2011
Localização: Portugal

Re: [+ ou - RESOLVIDO] Brilho some e não volta no elementary

Mensagempor Hmm » Sex, 26 de Dezembro 2014, 18:38

Obrigado. Antes eu experimentei o Ubuntu 14.10 e o brilho ajustava normalmente. Obs.: notebook acer aspire v3-571-6654, com windows 8.1 e uefi. Antes de tudo, criei partições no windows, desabilitei o security boot e uefi e instalei o linux (primeiro ubuntu, depois o tirei e substitui pelo elementary). Gostei muito do elementary, super rápido e belo visual, e até o momento muito estável, o único problema está sendo esse brilho. Abraço, Feliz Natal.

Hmm
 
Mensagens: 4
Registrado em: 26 Dezembro, 2014

AnteriorPróximo

Voltar para Outras distribuições de Linux

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 4 visitantes