Bem-vindo: Sáb, 29 de Abril 2017, 20:24 Pesquisa avançada

Wireless com adaptador só funciona segurando o botão Wi-fi

Secção dedicada aos browsers: Firefox, Google Chrome, Chromium, Opera e até aos demais desconhecidos. Apresentam-se novidades, extensões, questões, tweaks, tudo sobre estes navegadores! Sendo válido para todas as plataformas, Linux, MacOS e Windows!

Wireless com adaptador só funciona segurando o botão Wi-fi

Mensagempor privado » Ter, 7 de Março 2017, 3:46

Meu notebook é um Dell Latitude E5400 com dual boot com Windows 10 , no Windows 10 o Wifi usando Philips PTA-01 funciona normalmente, e no Ubuntu anterior versão 14.10 LTS funcionava corretamente , sempre que eu ligava eu precisava incluir 2 comando no terminal para ativar o wifi

sudo modprobe ath9k_htc
sudo echo 0471 209e > /sys/bus/usb/drivers/ath9k_htc/new_id

Tinha a opção de fixar o drive para não precisar fazer isso, mas era preciso fazer tanta coisa que preferi ativar assim pelo terminal todas as vezes, infelizmente depois que atualizei para 16.04 não funcionou mais o wifi, fiz vários procedimentos e nada, até que resolvi mexer na tecla física do wifi do notebook para ver se entrava pelo wifi do aparelho um Intel Wifi Link 5100 (AGN) , para minha surpresa o wifi nativo não funciona provavelmente por falta de drives, mas o Philips PTA-01 funcionou, só que o problema é o seguinte eu estou usando o Adaptador externo PTA-01 justamente pq o botão físico do notebook está quebrado e precisa ficar segurando, pressionando se não ele não funciona.

Agora , como deixar o PTA-01 ativado sem eu precisar fazer isso fisicamente ?
Mesmo que eu tenha que usar algum comando no terminal toda vez que ligar ?
Veja abaixo as informações do Wireless


privado@privado-tunel:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: phy1: Wireless LAN
Soft blocked: no
Hard blocked: no
2: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes

privado@privado-tunel:~$ sudo rfkill unblock all
[sudo] senha para privado: XXXXXXXXXXXXXXXXX


E continua bloqueado : :troll:

privado@privado-tunel:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: phy1: Wireless LAN
Soft blocked: no
Hard blocked: no
2: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
privado@privado-tunel:~$

Baixei um pacote de drives dessa página , mas não sei instalar
https://backports.wiki.kernel.org/index.php/Main_Page


Tentei baixar o firmware-atheros

com o comando sudo apt-get install firmware-atheros


Deu isso :

privado@privado-tunel:~$ sudo apt-get install firmware-atheros
[sudo] senha para privado:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
O pacote firmware-atheros não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'firmware-atheros' não tem candidato para instalação :troll:


TAMBÉM FIZ ESSE PROCEDIMENTO :

Baixei htc_9271.fw, e copiei ele para /lib/firmware , Mas não sei se fiz isso como root


OUTRA COISA AGORA QUANDO TENTO FAZER O QUE FAZIA ANTES NA VERSÃO 14.10
DIZ QUE NÃO TENHO PERMISSÃO , VEJA

privado@privado-tunel:~$ sudo modprobe ath9k_htc
privado@privado-tunel:~$ sudo echo 0471 209e > /sys/bus/usb/drivers/ath9k_htc/new_id
bash: /sys/bus/usb/drivers/ath9k_htc/new_id: Permissão negada


Porém me parece que o comando a seguir funciona, mas não como antes que habilitava o wifi na hora, agora preciso pressionar o botão e ficar segurando, dai sim ativa o wifi e o PT-A01 da Philips encontra as redes.

Alguém sabe como faço para não precisar usar o botão quebrado do wireless ? Como é impossível ficar segurando o botão só tenho usado com cabo. Alguém pode me ajudar ?

privado
 
Mensagens: 1
Registrado em: 07 Março, 2017

Re: Wireless com adaptador só funciona segurando o botão Wi

Mensagempor nuno_nunes » Sáb, 22 de Abril 2017, 10:16

Mande a marca e modelo dessa placa wireless para ver se tem algum modulo para esse modelo?
Avatar do usuário
nuno_nunes
 
Mensagens: 3931
Registrado em: 28 Maio, 2012
Localização: Pampilhosa da Serra - Portugal


Tópicos Similares:

Voltar para Browsers - Navegadores de Internet

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante