Bem-vindo: Seg, 16 de Dezembro 2019, 3:09 Pesquisa avançada

Problema com remoção do Kernel

Exponha aqui todas as dúvidas ou pontos de vista sobre a instalação do Ubuntu!

Re: Problema com remoção do Kernel

Mensagempor Miguel Fonseca » Sex, 13 de Dezembro 2013, 2:39

BollaBR (13-12-2013, 1:35) escreveu:Não! :\

Segue listagem

root@servidor:/lib/modules# ls
3.5.0-23-generic 3.5.0-31-generic 3.5.0-37-generic 3.5.0-41-generic 3.5.0-44-generic
3.5.0-28-generic 3.5.0-32-generic 3.5.0-39-generic 3.5.0-42-generic
3.5.0-30-generic 3.5.0-34-generic 3.5.0-40-generic 3.5.0-43-generic
root@servidor:/lib/modules#


Você quer acesso ao SSH?


Olha lá Bolla (eu estou a copiar os números de cima e a colá-los em baixo!):

cd /lib/modules


sudo rm -rf 3.5.0-23-generic 3.5.0-28-generic 3.5.0-30-generic


Executa lá os comandos, já que não estás a ver os "malandros" dos Kernels! :D

Depois:

sudo update-grub


sudo aptitude -f install


Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Problema com remoção do Kernel

Mensagempor BollaBR » Sex, 13 de Dezembro 2013, 2:42

Olhe os resultados:

root@servidor:/lib/modules# sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-41-generic
Found linux image: /boot/vmlinuz-3.5.0-40-generic
Found initrd image: /boot/initrd.img-3.5.0-40-generic
Found linux image: /boot/vmlinuz-3.5.0-32-generic
Found initrd image: /boot/initrd.img-3.5.0-32-generic
Found linux image: /boot/vmlinuz-3.5.0-31-generic
Found initrd image: /boot/initrd.img-3.5.0-31-generic
Found linux image: /boot/vmlinuz-3.5.0-30-generic
Found linux image: /boot/vmlinuz-3.5.0-28-generic
Found linux image: /boot/vmlinuz-3.5.0-23-generic
Found memtest86+ image: /memtest86+.bin
done
root@servidor:/lib/modules#


Resultado apttitude
root@servidor:/lib/modules# sudo aptitude -f install
E: /root/.aptitude - mkdir (2: Arquivo ou diretório não encontrado)
Os pacotes a seguir, parcialmente instalados, serão configurados:
samba samba-common samba-common-bin smbclient
Nenhum pacote será instalado, atualizado ou removido.
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 11 não atualizados.
É preciso obter 0 B de arquivos. Depois do desempacotamento, 0 B serão usados.
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
Nenhum relatório apport escrito pois MaxReports já foi atingido
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando smbclient (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois MaxReports já foi atingido
Nenhum relatório apport escrito pois MaxReports já foi atingido
Nenhum relatório apport escrito pois MaxReports já foi atingido
Erros foram encontrados durante o processamento de:
samba-common
samba-common-bin
samba
smbclient
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar:
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
dpkg: problemas de dependência impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando smbclient (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
samba-common
smbclient
samba-common-bin
samba

root@servidor:/lib/modules#

BollaBR
 
Mensagens: 31
Registrado em: 12 Dezembro, 2013

Re: Problema com remoção do Kernel

Mensagempor Miguel Fonseca » Sex, 13 de Dezembro 2013, 2:44

Pois, tenta agora:

sudo dpkg --configure --pending


E vê se ele já consegue configurar o Samba.

Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Problema com remoção do Kernel

Mensagempor BollaBR » Sex, 13 de Dezembro 2013, 2:45

Nada...

root@servidor:/lib/modules# sudo dpkg --configure --pending
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
dpkg: problemas de dependência impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando smbclient (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
samba-common
smbclient
samba-common-bin
samba
root@servidor:/lib/modules#

BollaBR
 
Mensagens: 31
Registrado em: 12 Dezembro, 2013

Re: Problema com remoção do Kernel

Mensagempor Miguel Fonseca » Sex, 13 de Dezembro 2013, 2:50

Bem, vamos ver se este comando "quebra o galho"!

sudo aptitude reinstall samba samba-common-bin samba-common smbclient


Se não der erro (se der, "posta" aqui!):

sudo aptitude -f install


Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Problema com remoção do Kernel

Mensagempor BollaBR » Sex, 13 de Dezembro 2013, 2:52

Deu erro novamente..

root@servidor:/lib/modules# sudo aptitude reinstall samba samba-common-bin samba-common smbclient
E: /root/.aptitude - mkdir (2: Arquivo ou diretório não encontrado)
Os pacotes a seguir serão REINSTALADOS:
samba samba-common samba-common-bin smbclient
0 pacotes atualizados, 0 novos instalados, 4 reinstalados, 0 a serem removidos e 11 não atualizados.
É preciso obter 0 B de arquivos. Depois do desempacotamento, 0 B serão usados.
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
Nenhum relatório apport escrito pois MaxReports já foi atingido
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois MaxReports já foi atingido
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois MaxReports já foi atingido
dpkg: problemas de dependência impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando smbclient (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois MaxReports já foi atingido
Erros foram encontrados durante o processamento de:
samba-common
samba-common-bin
samba
smbclient
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar:
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
dpkg: problemas de dependência impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando smbclient (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
samba-common
smbclient
samba-common-bin
samba

root@servidor:/lib/modules#

BollaBR
 
Mensagens: 31
Registrado em: 12 Dezembro, 2013

Re: Problema com remoção do Kernel

Mensagempor Miguel Fonseca » Sex, 13 de Dezembro 2013, 3:02

Está dificil!

Vamos ver se é desta!

sudo apt-get remove --purge samba-common samba-common-bin samba smbclient


sudo apt-get clean


sudo apt-get autoclean


sudo apt-get autoremove


sudo aptitude install samba


E vê se já vai!

Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Problema com remoção do Kernel

Mensagempor BollaBR » Sex, 13 de Dezembro 2013, 3:09

Nada denovo... :/

viso: falta ficheiro de lista de ficheiros `coreutils', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `linux-image-3.5.0-31-generic', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libnl-3-200', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libgl1-mesa-dri', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libxdmcp6', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libt1-5', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `shared-mime-info', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libpolkit-gobject-1-0', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `dash', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libltdl-dev', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `memtest86+', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libelf1', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `debconf', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `libtext-wrapi18n-perl', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `mysql-client-core-5.5', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `tcpd', assumindo que o pacote não tem actualmente ficheiros instalados.

dpkg: aviso: falta ficheiro de lista de ficheiros `python-pkg-resources', assumindo que o pacote não tem actualmente ficheiros instalados.
(Lendo banco de dados ... 4617 ficheiros e directórios actualmente instalados.)
Desempacotando libtalloc2 (de .../libtalloc2_2.0.7-3_i386.deb) ...
Selecionando pacote libtdb1 previamente não selecionado.
Desempacotando libtdb1 (de .../libtdb1_1.2.9-4_i386.deb) ...
Selecionando pacote libwbclient0 previamente não selecionado.
Desempacotando libwbclient0 (de .../libwbclient0_2%3a3.6.3-2ubuntu2.9_i386.deb) ...
Selecionando pacote samba-common previamente não selecionado.
Desempacotando samba-common (de .../samba-common_2%3a3.6.3-2ubuntu2.9_all.deb) ...
Selecionando pacote samba-common-bin previamente não selecionado.
Desempacotando samba-common-bin (de .../samba-common-bin_2%3a3.6.3-2ubuntu2.9_i386.deb) ...
Selecionando pacote samba previamente não selecionado.
Desempacotando samba (de .../samba_2%3a3.6.3-2ubuntu2.9_i386.deb) ...
Selecionando pacote tdb-tools previamente não selecionado.
Desempacotando tdb-tools (de .../tdb-tools_1.2.9-4_i386.deb) ...
Processando gatilhos para man-db ...
Processando gatilhos para ureadahead ...
Processando gatilhos para ufw ...
Configurando libtalloc2 (2.0.7-3) ...
Configurando libtdb1 (1.2.9-4) ...
Configurando libwbclient0 (2:3.6.3-2ubuntu2.9) ...
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
Nenhum relatório apport escrito pois MaxReports já foi atingido
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
Nenhum relatório apport escrito pois MaxReports já foi atingido
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Configurando tdb-tools (1.2.9-4) ...
Nenhum relatório apport escrito pois MaxReports já foi atingido
Processando gatilhos para libc-bin ...
Erros foram encontrados durante o processamento de:
samba-common
samba-common-bin
samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar:
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
samba-common
samba-common-bin
samba

root@servidor:/#

BollaBR
 
Mensagens: 31
Registrado em: 12 Dezembro, 2013

Re: Problema com remoção do Kernel

Mensagempor Miguel Fonseca » Sex, 13 de Dezembro 2013, 3:20

Bem, está dificil!

Puseste o teu SO completamente doido!

Vamos ver se vai!

sudo apt-get remove --purge samba-common samba-common-bin samba smbclient


sudo apt-get clean


sudo apt-get autoclean


sudo apt-get autoremove


sudo aptitude install coreutils linux-image-3.5.0-31-generic libnl-3-200 libgl1-mesa-dri libxdmcp6 libt1-5 shared-mime-info libpolkit-gobject-1-0 dash libltdl-dev memtest86+ libelf1 debconf libtext-wrapi18n-perl mysql-client-core-5.5 tcpd python-pkg-resources samba-common samba-common-bin samba smbclient


Se ele te der erro, a dizer que não encontra determinado pacote, coloca aqui para eu saber!

sudo dpkg --configure -a


Se o comando acima der erros, executa (senão, NÃO executes!):

sudo dpkg --configure --pending


Se não der erro nenhum :desdentado:

Executa:

sudo aptitude -f install


Aguardo.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Problema com remoção do Kernel

Mensagempor BollaBR » Sex, 13 de Dezembro 2013, 3:27

Cara ta complicado...

Não seria mais fácil você ter acesso ao SSH? :/

Veja:

root@servidor:/# sudo dpkg --configure --pending
Configurando samba-common (2:3.6.3-2ubuntu2.9) ...
dpkg: erro processando samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 10
dpkg: problemas de dependência impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando smbclient (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.
dpkg: erro processando samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.3-2ubuntu2.9); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.
dpkg: erro processando samba (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
samba-common
smbclient
samba-common-bin
samba
root@servidor:/#

BollaBR
 
Mensagens: 31
Registrado em: 12 Dezembro, 2013

AnteriorPróximo

Voltar para Instalação do Ubuntu

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes

cron