Bem-vindo: Qua, 16 de Outubro 2019, 15:39 Pesquisa avançada

CPU com processamento excessivo!

Secção relativa a ajustes! Divulgue aqui qualquer tipo de ajuste que possa melhorar/agilizar o sistema ou algum programa. Seja o mais detalhado possível na descrição do procedimento! Em caso de dúvida em algum ajuste pergunte nesta secção!

Re: CPU com processamento excessivo!

Mensagempor Miguel Fonseca » Sex, 6 de Abril 2012, 20:54

E então José, verifica-se uma redução, mas o que interessa saber é se a "quantidade" de processamento diminuiu?

Aguardo :p
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: CPU com processamento excessivo!

Mensagempor José Craveiro » Sex, 6 de Abril 2012, 20:59

Os níveis não sofreram alteração! :S
Para além das "turbinas" ainda não acalmarem, não noto falhas ou travamentos, contudo está mais quente.
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: CPU com processamento excessivo!

Mensagempor José Craveiro » Sex, 6 de Abril 2012, 21:01

Só uma pergunta, como é que posso voltar a uma versão de kernel anterior e assim quem sabe recuperar?
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: CPU com processamento excessivo!

Mensagempor Miguel Fonseca » Sex, 6 de Abril 2012, 21:02

Bem José, devo dizer-te que no meu Ubuntu 11.10 32 bits Unity também ontem tive o mesmo problema, os processadores sempre no máximo e as ventoinhas também.

Aconteceu depois de uma actualização do sistema e só voltou ao normal depois de reiniciar.

Nem sair da sessão resolveu, ou mesmo terminar o "X".

Mas como escrevi, depois de reiniciar voltou tudo ao normal.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: CPU com processamento excessivo!

Mensagempor José Craveiro » Sex, 6 de Abril 2012, 21:05

Pois, mas o reboot no meu caso não funcionou... :\
O problema só existe mesmo nesta sessão.
Mas, permanece a minha pergunta, se me puderem ajudar ficaria muito grato, talvez consiga resolver isto com esse método.
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: CPU com processamento excessivo!

Mensagempor Miguel Fonseca » Sex, 6 de Abril 2012, 21:20

Bem José, tens ideia se nas "tais" actualizações que fizeste, houve alguma feita especificamente ao Kernel?

Talvez seja uma boa ideia instalares a última versão estável, a 3.3.1, que vem já com um "patch" especialmente indicado para "laptops" no intuito de resolver os problemas de energia.

Dá uma olhada neste artigo (em Inglês), que ficarás com uma ideia do que estou a falar.

http://www.h-online.com/open/news/item/Linux-3-4-will-use-Intel-s-power-saving-RC6-GPU-technology-1503382.html

Embora se refira ao 3.4 (próxima versão), a partir do 3.3, já foram tomadas medidas para a resolução de muitos dos problemas de consumo e processamento do Kernel.

É este o Kernel que utilizo (3.3.1) e não me deu problemas nenhuns! Inclusive aumentou a velocidade de navegação, abertura de programas, etc e vi uma melhoria no consumo.

Se quiseres dar uma olhada nas versões (todas) disponíveis do Kernel Linux, inclusive uma Release Candidate do 3.4, segue este link:

http://kernel.ubuntu.com/~kernel-ppa/mainline/

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: CPU com processamento excessivo!

Mensagempor Claudio Novais » Sex, 6 de Abril 2012, 22:59

José, experimente arrancar com um kernel mais antigo (isto porque neste momento estão a falar sobre ele). Entretanto, não mostrou o output do top!
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011

Re: CPU com processamento excessivo!

Mensagempor José Craveiro » Sáb, 7 de Abril 2012, 0:49

Cláudio, relativamente à última MP:

Código: Selecionar todos
jose@jose-Compaq-Presario-CQ60-Notebook-PC:~$ top -n 1

top - 00:30:28 up 3 min,  0 users,  load average: 0.14, 0.22, 0.10
Tasks: 138 total,   3 running, 134 sleeping,   0 stopped,   1 zombie
Cpu(s): 47.8%us, 16.7%sy,  0.3%ni, 27.5%id,  7.6%wa,  0.0%hi,  0.1%si,  0.0%st
Mem:   2059752k total,   642508k used,  1417244k free,    70992k buffers
Swap:  6431740k total,        0k used,  6431740k free,   317548k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 1752 jose      20   0  205m  14m 9.8m R   97  0.7   1:51.00 xfce4-systemloa   
 1595 root      20   0 62644  42m  13m R   76  2.1   1:22.85 Xorg               
 1714 jose      20   0 24560  10m 8484 S   17  0.5   0:16.93 xfwm4             
    1 root      20   0  3336 1828 1248 S    0  0.1   0:00.55 init               
    2 root      20   0     0    0    0 S    0  0.0   0:00.00 kthreadd           
    3 root      20   0     0    0    0 S    0  0.0   0:00.03 ksoftirqd/0       
    4 root      20   0     0    0    0 S    0  0.0   0:00.03 kworker/0:0       
    5 root      20   0     0    0    0 S    0  0.0   0:00.30 kworker/u:0       
    6 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0       
    7 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/1       
    8 root      20   0     0    0    0 S    0  0.0   0:00.00 kworker/1:0       
    9 root      20   0     0    0    0 S    0  0.0   0:00.03 ksoftirqd/1       
   10 root      20   0     0    0    0 S    0  0.0   0:00.59 kworker/0:1       
   11 root       0 -20     0    0    0 S    0  0.0   0:00.00 cpuset             
   12 root       0 -20     0    0    0 S    0  0.0   0:00.00 khelper           
jose@jose-Compaq-Presario-CQ60-Notebook-PC:~$ top -n 5

top - 00:33:42 up 6 min,  0 users,  load average: 0.14, 0.16, 0.10
Tasks: 136 total,   4 running, 131 sleeping,   0 stopped,   1 zombie
Cpu(s): 73.4%us, 22.8%sy,  0.0%ni,  3.7%id,  0.0%wa,  0.0%hi,  0.2%si,  0.0%st
Mem:   2059752k total,   680796k used,  1378956k free,    71072k buffers
Swap:  6431740k total,        0k used,  6431740k free,   348288k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 1752 jose      20   0  205m  14m 9.8m R   99  0.7   4:53.78 xfce4-systemloa   
 1595 root      20   0 62780  42m  13m R   76  2.1   3:41.95 Xorg               
 1714 jose      20   0 24560  10m 8484 S   17  0.5   0:45.48 xfwm4             
 2046 jose      20   0  2828 1148  856 R    0  0.1   0:00.03 top               
    1 root      20   0  3336 1828 1248 S    0  0.1   0:00.56 init               
    2 root      20   0     0    0    0 S    0  0.0   0:00.00 kthreadd           
    3 root      20   0     0    0    0 S    0  0.0   0:00.04 ksoftirqd/0       
    6 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/0       
    7 root      RT   0     0    0    0 S    0  0.0   0:00.00 migration/1       
    9 root      20   0     0    0    0 S    0  0.0   0:00.03 ksoftirqd/1       
   10 root      20   0     0    0    0 S    0  0.0   0:00.59 kworker/0:1       
   11 root       0 -20     0    0    0 S    0  0.0   0:00.00 cpuset             
   12 root       0 -20     0    0    0 S    0  0.0   0:00.00 khelper           
   13 root       0 -20     0    0    0 S    0  0.0   0:00.00 netns             
   15 root      20   0     0    0    0 S    0  0.0   0:00.00 sync_supers       
jose@jose-Compaq-Presario-CQ60-Notebook-PC:~$


Entretanto verifiquei como decorria no pc e também foi "contaminado pela adrenalina do CPU's" :roll:
Uma das VMs que tenho com apenas o Xubuntu, atualizei normalmente e verifiquei que material à base de Kernel foi instalado. Pois aqui o Xubuntu funciona muito suave como habitualmente.
Curiosamente o mesmo não sucedeu com outra VM com base Ubuntu padrão e com sessão xubuntu onde ficou com o mesmo problema! Nesta VM, tal como sucede com o portátil, a sessão xubuntu entra em ebulição e nas outras sessões que lá tenho está tudo calmo. :(
À parte disto, a 1ª VM que referi foi atualizada há instantes, a 2ª já foi hoje (aliás ontem à tarde), será que a que atualizei agora já vem com alguma correção pelo facto de estar operacional? É só dúvidas... grrrr

Quanto a arrancar com um kernel mais antigo, cheguei a fazer isso, mas não só não fixa quando faço reboot porque volta ao mais atual, como também notei que enquanto está sob o kernel antigo, o elevado processamento mantém-se! :o

Logo agora isto tinha que acontecer, bom se não houver resolução, sempre posso usar as outras sessões que permanecem calmas... :facepalm:
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: CPU com processamento excessivo!

Mensagempor Claudio Novais » Sáb, 7 de Abril 2012, 0:54

Pois, não sei! Mas só uma pergunta, você quando executou o comando tinha o monitor do sistema aberto? é que estranhamente ele continua ali ativo! Entretanto estranhamente temos ali outro processo que está a gastar muitos recursos, o Xorg!
Avatar do usuário
Claudio Novais
Editor do Ubuntued
 
Mensagens: 16869
Registrado em: 25 Maio, 2011

Re: CPU com processamento excessivo!

Mensagempor José Craveiro » Sáb, 7 de Abril 2012, 0:59

Sim, verifiquei o monitor de sistema, mas desliguei antes de fazer esta colheita de dados, agora será que o aplet da barra está aqui a causar alguma interferência?
Estranho é que a 1ª VM de que falei está a causar aqui alguma confusão!
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

AnteriorPróximo

Voltar para Tweaks/Ajustes ao sistema ou a programas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 5 visitantes