Bem-vindo: Dom, 20 de Outubro 2019, 12:55 Pesquisa avançada

USB no VirtualBox [RESOLVIDO]

Secção relativa a ajustes! Divulgue aqui qualquer tipo de ajuste que possa melhorar/agilizar o sistema ou algum programa. Seja o mais detalhado possível na descrição do procedimento! Em caso de dúvida em algum ajuste pergunte nesta secção!

USB no VirtualBox [RESOLVIDO]

Mensagempor lucasC¨ » Sáb, 21 de Janeiro 2012, 3:05

Boas pessoal!

To com problemas para fazer com que o VirtualBox identifique os dispositivos USB.
Venho pedir ajuda pois percebo que o problema que eu estou enfrentando é, de certa forma, atípico.
Digo isso pois pesquisei bastante e todas aspossíveis soluções encontradas não surtiram efeito.

Estou utilizando o Ubuntu 10.10 e o VirtualBox 4.1. A maquina virtual é Windows 7.

Normalmente, pelo que notei nos relatos de outros utilizadores, o "problema" é de simples solução.
Basta ter instalado a extensão VirtualBox Extension Pack, os adicionais para convidados, e adicionar-me ao grupo vboxusers. Feito isso o pendrive e demais dispositivos USB serão reconhecidos.

O problema é que o grupo vboxusers não existe. Até ai tudo bem, pois basta criá-lo. Contudo, assim que eu adiciono o grupo vboxusers e o mesmo desaparece. Isto é, assim que eu crio o grupo acessando Sistema>Adiministração>Usuários e grupos>Gerenciar grupos, o mesmo some assim que eu fecho a janela. Não adianta reiniciar o sistema.
Além disso, acessandoConfigurações avançadas>Privilégios do Usuário, não existe a opção “Usar a solucao de virtualização VirtualBox”.

Surge então a minha dúvida: É normal o grupo vboxusers não existir? Ele não deveria ser criado automaticamente na instalação do VirtualBox?

Tudo está funcionando perfeitamente, exceto o USB. E o objetivo do VirtualBox e do Windows é justamente utilizar um periférico USB - multifuncional Epson que funciona perfeitamente no ubuntu, inclusive o scanner, mas não é possível visualizar o nível de tinta. :facepalm2:

Bom, se alguém souber como eu devo proceder, agradeço a ajuda desde já. :obrigado:
Editado pela última vez por lucasC¨ em Qua, 25 de Janeiro 2012, 23:47, em um total de 1 vez.
Lucas Caitano
Avatar do usuário
lucasC¨
 
Mensagens: 15
Registrado em: 21 Junho, 2011

Re: USB no VirtualBox

Mensagempor Miguel Fonseca » Sáb, 21 de Janeiro 2012, 4:45

Boas LucasC, por acaso tens instalado o pacote dkms?

Se não o tens instala-o:

sudo apt-get install dkms


e também o pacote dkms do VirtualBox que tens instalado, ou seja ou o normal ou o "ose".

Depois vê se isso te solucionou o problema com o VBoxUser Group.

Caso já tenhas os pacotes acima referidos instalados, vê nas configurações do Virtual Box relativas ao Windows se tens o suporte para USB activo.

Se tudo o referi já tens e verificaste, então, para já, não sei como ajudar-te.

Posso dizer que no meu caso, Ubuntu 11.10 32bits, assim que instalei o pacote dkms e em seguida o VirtualBox, foi criado automaticamente o VBoxUser Group.

De qualquer maneira, deixa aqui a tua resposta e eu vou ver se encontro algo mais sobre o assunto.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: USB no VirtualBox

Mensagempor lucasC¨ » Sáb, 21 de Janeiro 2012, 18:43

Olá Miguel!
Obrigado pela rápida resposta!!

Quanto ao pacote dkms, já o tenho instalado.
Quanto ao VirtualBox, tomei cuidado para não instalar a versão OSE pois pelo que li, esta não possui suporte a USB.

Quanto ao suporte a USB ativo, sim o ativei. Contudo, o VirtualBox diz não ter nenhum dispositivo USB conectado.
Nas imagens abaixo, é possível ver que existe um pendrive conectado que não é identificado no VirtualBox.

Imagem Imagem Imagem Imagem

É claro que o meu problema não é acessar o pendrive. Este eu acesso facilmente pois o compartilhamento de pastas esta ativo e funcionando. Logo basta compartilhar a pasta onde o pendrive é montado...

Porém o mesmo não é possível com a impressora e a webcam, por exemplo.
Lucas Caitano
Avatar do usuário
lucasC¨
 
Mensagens: 15
Registrado em: 21 Junho, 2011

Re: USB no VirtualBox

Mensagempor Miguel Fonseca » Dom, 22 de Janeiro 2012, 3:00

Boas LucasC, também sei que a versão OSE não dá suporte a USB, por isso é que referi isso no meu "post" mas esqueci de mencionar porquê :lol: !

Faz o seguinte a ver se resulta:

Abre o VirtualBox, mas não arranques com o Windows 7;

Em seguida vai ao menu de Settings (Preferências) do Windows 7 e selecciona para Enable (ligado) o suporte para USB;

Liga o equipamento que queres usar (exemplo a impresora) por USB, clica no botão pequeno que se encontra do lado direito que diz: "add filter from device" (adicionar filtro ao equipamento ou algo do género), selecciona o teu aparelho (ex. impressora) e certifica-te que está Enable (ligado), "dá" um OK;

Certifica-te que tudo o que foi mudado acima está guardado (save) e arranca com o Windows 7, liga (por USB) o teu equipamento (ex, impressora) e o Windows 7 deverá agora reconhecer normalmente os USB.

Em alguns casos, deverás clicar com o botão do lado direito do rato no ícone do USB que se encontra no canto inferior direito da janela do VirtualBox e seleccionares o equipamento USB em questão para o ligares (Enable) ou desligares (Disable)
do Sistema Operativo convidado (guest). No teu caso para o ligares ou desligares do Windows 7.

Depois "posta" aqui se isto ajudou.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: USB no VirtualBox

Mensagempor lucasC¨ » Dom, 22 de Janeiro 2012, 3:57

Ola Miguel!

Tentei fazer o que recomendou mas não surtiu efeito. Isso por que segundo o VirtualBox não há "nenhum dispositivo disponível". Portanto não é possível selecionar a impressora ou outro dispositivo qualquer conectado as portas USB. :\
Li em alguns lugares utilizadores relatando que o dispositivo aparecia na lista de dispositivos mas não podia ser selecionado. Contudo, no meu caso nem isso acontece.

Já tentei reinstalar o VirtualBox (mesma versão) e as extensões... o que também não resolveu. Fiz isso por que achei que o grupo vboxusers poderia ser criado caso eu reinstalasse.
Talvez eu tente instalar uma versão anterior pra ver se o problema se resolve.

Tenho outra pergunta a fazer, agora quanto a aceleração de video 2D e 3D. Eu as ativei mas no Windows 7 surge uma mensagem afirmando que não há suporte para aceleração 3D. No teu caso a aceleração funciona?

Agradeço a ajuda!!
Lucas Caitano
Avatar do usuário
lucasC¨
 
Mensagens: 15
Registrado em: 21 Junho, 2011

Re: USB no VirtualBox

Mensagempor Miguel Fonseca » Dom, 22 de Janeiro 2012, 4:26

lucasC¨ » Dom Jan 22, 2012 3:57 am escreveu:Ola Miguel!

Tentei fazer o que recomendou mas não surtiu efeito. Isso por que segundo o VirtualBox não há "nenhum dispositivo disponível". Portanto não é possível selecionar a impressora ou outro dispositivo qualquer conectado as portas USB. :\
Li em alguns lugares utilizadores relatando que o dispositivo aparecia na lista de dispositivos mas não podia ser selecionado. Contudo, no meu caso nem isso acontece.

Já tentei reinstalar o VirtualBox (mesma versão) e as extensões... o que também não resolveu. Fiz isso por que achei que o grupo vboxusers poderia ser criado caso eu reinstalasse.
Talvez eu tente instalar uma versão anterior pra ver se o problema se resolve.

Tenho outra pergunta a fazer, agora quanto a aceleração de video 2D e 3D. Eu as ativei mas no Windows 7 surge uma mensagem afirmando que não há suporte para aceleração 3D. No teu caso a aceleração funciona?

Agradeço a ajuda!!


Boas LucasC, quanto à aceleração 3D, nas preferências/definições (settings), terás que definir a aceleração 3D e, dependendo da tua placa gráfica e da quantidade de RAM que disponibilizaste para o Windows 7, poderá ou não ser possível a teres, ou mesmo a tendo, poderá não ajudar.
No meu caso, só tenho 512MB na minha ATI e, juntamente com os 2GB de RAM, não me é possível ter a aceleração 3D a funcionar em "pleno" devido à falta de MB, tanto na placa como na RAM.
Todos os sistemas operativos mais recentes, pedem também, virtualização de Hardware (feito a nível dos processadores), que eu também não possuo! :cry: Logo, não me é possível instalar a maior parte desses mais recentes Sistemas Operativos em ambiente virtual :facepalm: .
Como tal, ou os testo em LiveCD, ou os instalo em Dual-Boot (ou mais se necessário).
Tenho instalado neste momento, o Ubuntu 11.10 32bits e o Windows 7 32bits em Dual-Boot.
Experimenta activar a aceleração e veres se funciona, tendo em conta aqueles parâmetros que referi mais acima.

Quanto ao 1º problema, só por curiosidade, "posta" aqui o conteúdo do teu ficheiro
/etc/udev/rules.d/10-vboxdrv.rules . Para tal, no terminal:

gedit /etc/udev/rules.d/10-vboxdrv.rules


copia e cola aqui o resultado.

Talvez ainda dê para se tentar outra solução.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: USB no VirtualBox

Mensagempor lucasC¨ » Dom, 22 de Janeiro 2012, 15:35

Olá Miguel!

O conteúdo do ficheiro /etc/udev/rules.d/10-vboxdrv.rules é:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"



Quanto a aceleração 3D, já desisti... Meu processador é um i5 M450 (2,4 GHz) e suporta tranquilamente todos os efeitos do Compiz (e eu tenho praticamente todos ativos juntamente). Além disso, consigo executar filmes fullhd com perfeição além de alguns jogos em boa qualidade. Já tentei dedicar à maquina virtual 128 MB de video e 2 Gb de memória (dos 4 no total) e mesmo assim não funcionou... Paciência :S

Quanto ao Dual-Boot, sem dúvida é uma boa ideia. Porém alguns fatores me fazem pensar duas vezes.
Eu teria que instalar o Windows e depois o Ubuntu (não sei como instalar o Windows já tendo o Ubuntu instalado). E eu não gostaria de desinstalar o meu Ubuntu apesar de já ter os backups de todas as configurações salvos.
Eu nem mesmo atualizei a versão do meu Ubuntu (ainda estou na 10.10) de tão agradável que está sua utilização. :D

Além disso, me parece muito mais atraente a possibilidade de utilizar o Windows 7 em uma janela dentro do Ubuntu, visto que o sistema que realmente utilizo é o Ubuntu...
Lucas Caitano
Avatar do usuário
lucasC¨
 
Mensagens: 15
Registrado em: 21 Junho, 2011

Re: USB no VirtualBox

Mensagempor Miguel Fonseca » Seg, 23 de Janeiro 2012, 2:03

lucasC¨ » Dom Jan 22, 2012 3:35 pm escreveu:Olá Miguel!

O conteúdo do ficheiro /etc/udev/rules.d/10-vboxdrv.rules é:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"



Quanto a aceleração 3D, já desisti... Meu processador é um i5 M450 (2,4 GHz) e suporta tranquilamente todos os efeitos do Compiz (e eu tenho praticamente todos ativos juntamente). Além disso, consigo executar filmes fullhd com perfeição além de alguns jogos em boa qualidade. Já tentei dedicar à maquina virtual 128 MB de video e 2 Gb de memória (dos 4 no total) e mesmo assim não funcionou... Paciência :S

Quanto ao Dual-Boot, sem dúvida é uma boa ideia. Porém alguns fatores me fazem pensar duas vezes.
Eu teria que instalar o Windows e depois o Ubuntu (não sei como instalar o Windows já tendo o Ubuntu instalado). E eu não gostaria de desinstalar o meu Ubuntu apesar de já ter os backups de todas as configurações salvos.
Eu nem mesmo atualizei a versão do meu Ubuntu (ainda estou na 10.10) de tão agradável que está sua utilização. :D

Além disso, me parece muito mais atraente a possibilidade de utilizar o Windows 7 em uma janela dentro do Ubuntu, visto que o sistema que realmente utilizo é o Ubuntu...


Boas LucasC, faz o seguinte, no terminal:

sudo gedit /etc/udev/rules.d/10-vboxdrv.rules


colocas a tua password e, dentro do ficheiro, logo na primeira linha:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"

muda para o seguinte:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0666"

só mudas portanto, o valor do MODE="0600" para MODE="0666".
Guarda o ficheiro e inicia o teu VirtualBox e o Windows 7, vê se os teus dispositivos USB já são reconhecidos.

TEM EM CONTA, que este último procedimento é feito tendo em conta o que foi dito no outro "post"!
Ou seja, fazes primeiro o que indiquei atrás e depois esta parte. Então, arrancas com o Windows 7 e diz-me se resultou.

Devo-te também dizer que, como podes ver nesse teu ficheiro, que tens o VirtualBox User Group criado (GROUP="root").

Em último caso, mas NÃO como resolução para o teu problema, poderás arrancar com VirtualBox do terminal como "root" (administrador):

sudo virtualbox


e, em principio os teus USB vão ser TODOS reconhecidos.
Como eu escrevi acima, isto NÃO É SOLUÇÃO! É apenas um "workaround" que, em principio irá servir para te desenrascares no caso de necessitares de imprimir algo.

Porque NUNCA é aconselhável "arrancar" com um programa em MODO ADMINISTRADOR (root), por uma questão de segurança. Mas para te desenrascares dá :lol: .

Em relação ao Dual-Boot, estando dentro do Ubuntu, abre o Gparted (está nos repositórios), cria uma nova partição com o formato NTFS (pois o Windows não reconhece EXT), com cerca de no mínimo 25GB (eu tenho 70 GB), de seguida reinicia já com o DVD, CD, PEN USB ou imagem ISO do Windows 7 e executa a instalação do mesmo na PARTIÇÃO QUE CRIASTE, NÃO NA DO UBUNTU.
Deixa instalar até ao fim normalmente e, quando reiniciares, duas coisas poderão acontecer:

Ou te irá dar apenas a hipótese de arrancar com o Windows 7;
Ou irá aparecer uma mensagem no ecrã a dizer que não encontrou o Grub.

Para qualquer das situações, só tens que reiniciar o PC com o CD do Ubuntu 10.10, escolheres o modo live, ou seja, experimentar o Ubuntu sem instalar e seguires as indicações neste link:

http://www.lancelhoff.com/restore-grub2-after-installing-windows/

Caso tenhas alguns problemas com a língua Inglesa, os comandos no terminal são bem perceptíveis e o Google Chrome tem a capacidade de traduzir as páginas :D .

Não te assustes com os comandos, pois acaba por ser bastante fácil seguindo as indicações.

Quando precisei de recuperar o meu Grub numa situação semelhante, usei os seguintes comandos (algumas diferenças em relação aos do link que te deixei):

Tudo no terminal depois de ter arrancado com o Live CD como descrito acima:

sudo fdisk -l


colocas a tua password e, no meu caso, apareceu isto:

miguelfonseca@miguelfonseca-PC:~$ sudo fdisk -l
[sudo] password for miguelfonseca:

Disco /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total de 312581808 setores
Unidades = setores de 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador do disco: 0x8d4a48a8

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1 * 63 162259648 81129793 7 HPFS/NTFS/exFAT
/dev/sda2 162260992 168552967 3145988 82 Linux swap / Solaris
/dev/sda3 168554494 312580095 72012801 5 Estendida
/dev/sda5 168554496 312580095 72012800 83 Linux

Disco /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total de 976773168 setores
Unidades = setores de 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador do disco: 0x7611f7e1

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sdb1 * 63 976751999 488375968+ 7 HPFS/NTFS/exFAT

Como podes ver a Bold (negrito), está a partição onde tenho instalado o meu Ubuntu:

/dev/sda5 168554496 312580095 72012800 83 Linux

no teu caso, deverá ser outra partição, até porque vais instalar o Ubuntu depois do Windows 7, ao contrário de mim.
Escolhe a que diz SÓ "Linux".

De seguida, ainda no terminal, executa este comando:

sudo mount -t ext4 /dev/sda5 /mnt


colocas a tua password e ENTER.

TER ATENÇÃO: quando executaste o comando "sudo fdisk -l", tens de ver o tipo de ficheiros que tens (no meu caso ext4), podes conferir isso, abrindo o Gparted e na partição do Ubuntu, aparecerá o tipo de ficheiros (aquele que escolheste na instalação do teu Ubuntu).
TER ATENÇÃO TAMBÉM: que deverás substituir o valor "sda5" pela tua partição, que como referi acima deverá ser quase de certeza diferente da minha.

Para terminar, no terminal, executa este comando:

sudo grub-install --root-directory=/mnt /dev/sda


coloca a tua password e ENTER.

Agora é só reiniciar o PC e, se tudo correu bem, já irás ter à tua disposição a escolha entre o Ubuntu ou o Windows 7.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: USB no VirtualBox

Mensagempor lucasC¨ » Seg, 23 de Janeiro 2012, 16:00

Boas Miguel!

Fiz a mudança no valor MODE="0600" para MODE="0666". Refiz tudo o que me indicaste anteriormente... Mas os dispositivos USB continuam sem ser reconhecidos... :cry:
E quanto a executar o VirtualBox como root, aconteceu o seguinte:
Abre-se a janela do VirtualBox sem nenhuma maquina virtual criada. Isso é normal?
Eu já tinha exportado a algum dias maquina virtual que utilizo, quando reinstalei o VirtualBox, e até cogitei importá-la executando o VirtualBox como root. Não o fiz por que achei que pudesse ficar duplicada esta maquina em meu sistema...

Além disso, ao executar o VirtualBox como root, é listado algum erro referente ao kde (eu o instalei para testar e ainda o tenho).

Agradeço imensamente a perfeita explicação sobre a instalação do Dual-Boot. Muito clara por sinal! :yeah:
Seguirei os passos ainda esta semana!
Lucas Caitano
Avatar do usuário
lucasC¨
 
Mensagens: 15
Registrado em: 21 Junho, 2011

Re: USB no VirtualBox

Mensagempor Bitetti » Seg, 23 de Janeiro 2012, 16:28

Offtopic
Quanto a aceleração 3D, já desisti... Meu processador é um i5 M450 (2,4 GHz) e suporta tranquilamente todos os efeitos do Compiz (e eu tenho praticamente todos ativos juntamente). Além disso, consigo executar filmes fullhd com perfeição além de alguns jogos em boa qualidade. Já tentei dedicar à maquina virtual 128 MB de video e 2 Gb de memória (dos 4 no total) e mesmo assim não funcionou... Paciência

O VMWare tem melhor aceleração 3D doque com a VirtualBox, mas NÃO use o VMWare com o Ubuntu 11.10, não sei se é só no meu PC mas ele simplesmente dfunde LAG por todo o SO hospedeiro quando liga.

E as USB consigo que funcionem melhor com ele também.

vc ta usando uma instalação limpa do Ubuntu?
Avatar do usuário
Bitetti
 
Mensagens: 875
Registrado em: 03 Janeiro, 2012
Localização: São Paulo

Próximo

Voltar para Tweaks/Ajustes ao sistema ou a programas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 5 visitantes

cron