Bem-vindo: Qua, 16 de Outubro 2019, 3:35 Pesquisa avançada

Última tentativa....

Apresente-se nesta secção! Queremos conhecê-lo! Seja novo ou não no Ubuntued, apresente-se! Partilhe os seus gostos, o seu desktop, o seu blog, site, forum, twitter, facebook!

Re: Última tentativa....

Mensagempor Miguel Fonseca » Qui, 24 de Maio 2012, 16:30

Ok Exadra, só apresentei mais esta solução, pois era mais pormenorizada que as outras.

Mas visto que começaste do "zero", então que corra tudo bem.

Depois "posta" aqui o resultado desta tua aventura e qualquer dúvida que tenhas.

Cumos.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Última tentativa....

Mensagempor exadra37 » Qui, 24 de Maio 2012, 16:44

Miguel Fonseca » Qui Mai 24, 2012 4:30 pm escreveu:Ok Exadra, só apresentei mais esta solução, pois era mais pormenorizada que as outras.

Mas visto que começaste do "zero", então que corra tudo bem.

Depois "posta" aqui o resultado desta tua aventura e qualquer dúvida que tenhas.

Cumos.


Eu agradeço a solução apresentada, mas infelizmente não resultou também...

O resultado da instalação do ubuntu foi ficar sem windows de novo :rox:

Mas desta vez ficou resolvido com a utilização do comando LILO na consola do terminal, como já tinha sido referido anteriormente...

Agora estou sem Ubuntu :facepalm: .... qual é o comando para o recuperar?
Avatar do usuário
exadra37
 
Mensagens: 181
Registrado em: 23 Maio, 2012
Localização: Setúbal

Re: Última tentativa....

Mensagempor Miguel Fonseca » Qui, 24 de Maio 2012, 17:12

Bem Exadra, só instalaste o Windows de novo, ou também o Ubuntu?

De qualquer maneira, "arranca" o PC com o CD/DVD/Pen de Ubuntu 12.04 (tem de ser esta versão!) e escolhe experimentar o Ubuntu.

Quando entrares no modo LIve, abre o terminal e executa este comando:

sudo fdisk -l


Cola aqui o resultado deste comando e mantém-te no Ubuntu para que te possa dar a indicação de como recuperares o Ubuntu.

Aguardo.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Última tentativa....

Mensagempor exadra37 » Qui, 24 de Maio 2012, 17:24

Instalei os dois de novo...

Código: Selecionar todos
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2f5b761c

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   153602047    76800000    7  HPFS/NTFS/exFAT
/dev/sda2       153602048   358402047   102400000    7  HPFS/NTFS/exFAT
/dev/sda3       358402048   399362047    20480000   83  Linux
/dev/sda4       399362048   976773119   288705536    5  Extended
/dev/sda5       399364096   419844095    10240000   82  Linux swap / Solaris
/dev/sda6       419846144   976773119   278463488   83  Linux

Disk /dev/sdb: 8027 MB, 8027897856 bytes
14 heads, 22 sectors/track, 50907 cylinders, total 15679488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x04030201

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2232    15679487     7838628    b  W95 FAT32
ubuntu@ubuntu:~$


Ja tentei seguir o tutorial http://ubuntued.info/como-recuperar-o-grub mas da erro

Código: Selecionar todos
ubuntu@ubuntu:~$ sudo grub
sudo: grub: command not found
ubuntu@ubuntu:~$
Avatar do usuário
exadra37
 
Mensagens: 181
Registrado em: 23 Maio, 2012
Localização: Setúbal

Re: Última tentativa....

Mensagempor Miguel Fonseca » Qui, 24 de Maio 2012, 17:29

Bem Exadra, só instalaste um Ubuntu?

Se sim, instalaste a Home e a Root separadas?

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Última tentativa....

Mensagempor exadra37 » Qui, 24 de Maio 2012, 17:35

So instalei um Ubuntu....

A root está separada numa partição só para ela, a sda3 .

O SWAP e a Home estão na mesma mesma partição sda4, nas unidades logicas sda5 e sda6 respectivamente.

No gparted diz que a sda3 e a sda6 não estão montadas.
Avatar do usuário
exadra37
 
Mensagens: 181
Registrado em: 23 Maio, 2012
Localização: Setúbal

Re: Última tentativa....

Mensagempor Miguel Fonseca » Qui, 24 de Maio 2012, 17:38

Ok, abre o terminal:

sudo mount -t ext4 /dev/sda3 /mnt


sudo grub-install --root-directory=/mnt /dev/sda


Reinicia o PC e vê se já te aparece o menu do Grub, com as opções para arrancar com o Ubuntu e o Windows.

Aguardo.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Última tentativa....

Mensagempor exadra37 » Qui, 24 de Maio 2012, 17:52

:facepalm: :doh: :rox:

Então só agora é que percebi que o dual-boot não é feito com o ecra do windows mas sim com o Grub...

Assim sendo o Windows não desapareceu após a instalação do Ubuntu (nesta ultima instalação) ... estive eu a executar o restauro da MBR do windows e depois do Grub para nada :facepalm2:

Vivendo e aprendendo xD
Avatar do usuário
exadra37
 
Mensagens: 181
Registrado em: 23 Maio, 2012
Localização: Setúbal

Re: Última tentativa....

Mensagempor Miguel Fonseca » Qui, 24 de Maio 2012, 17:55

Sério Exadra?! o.0 :desdentado:

Então não estava nada errado?

Ora bolas! :\ grrrr

Bem, o que interessa é que tens tudo a funcionar bem agora, certo?

Cumps
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Última tentativa....

Mensagempor exadra37 » Qui, 24 de Maio 2012, 18:20

Eu penso que não estava nada errado, porque nesta 2a instalação, após formatar todas as partiçoes do disco e de ter instalado primeiro o windows e depois o Ubuntu, pensei que o dual-boot se efectuava pelo windows e como só me aparecia o Grub eu pensei que tinha ficado de novo sem windows :ups:

Afinal o dual-boot é feito pelo Grub, pelo que penso que se tivesse experimentado arrancar o windows pela opção do Grub, após a instalação do Ubuntu que teria funcionado, como funcionou agora ;)

Já me deu umas quantas janelas de erros... se for sempre assim torna-se um bocado chato :evil:

Mais logo vou actualiza-lo e personaliza-lo e depois logo vejo...

Obrigado por toda a ajuda, que todos vocês dispensaram :yeah:
Avatar do usuário
exadra37
 
Mensagens: 181
Registrado em: 23 Maio, 2012
Localização: Setúbal

AnteriorPróximo

Voltar para Apresente-se!

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante