Bem-vindo: Sex, 6 de Dezembro 2019, 0:31 Pesquisa avançada

Ubuntu 12.04 Precise Pangolin – Resolvendo problema com Java

Tem um artigo interessante e importante para a comunidade? Quer apresentar um software que acabou de conhecer? Ou até um software ou script seu? Então veja nesta secção como o redigir corretamente para publicar artigos no Blog do Ubuntued!

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Ron Alon » Sáb, 5 de Maio 2012, 1:19

Miguel72 » Sex Mai 04, 2012 12:02 pm escreveu:
ron » Sex Mai 04, 2012 2:24 pm escreveu:HAHAHA Tudo bem, Miguel! :lol:

Mas acho que isso já vai de escolha do próprio utilizador. Imagina só: toda vez que você precisar instalar o Java numa máquina, fazer todo aquele procedimento? O PPA é bem mais fácil mesmo, fazer o quê?


Sim ron, o PPA é mais fácil!! Se dúvida nenhuma!!!

Mas leste o meu "post"?

E se o PPA não tiver sempre actualizado?!

Vais continuar com uma versão desactualizada do Java até quando?!

Se tens lido as últimas notícias, terás lido sem dúvida sobre os vários problemas de segurança pelos quais o Java tem passado!

Então, se o PPA se mantiver actualizado, tudo bem, eu também o farei.

Mas caso contrário, é sempre bom sabermos como fazer para instalá-lo manualmente e da forma mais simples, rápida e eficiente possível.

Cumps.


Li sim - e entendo isso. Mas enquanto tiver um ppa, estarei eu atualizando. O pessoal que fez este PPA atualiza sempre os ppas (utilizo alguns deles aqui) e sempre que sai algo estável. Então creio que vão atualizar tudo isto sim.

Cumps! =)
Avatar do usuário
Ron Alon
Redator Geekzinho
 
Mensagens: 4145
Registrado em: 27 Julho, 2011
Localização: São Vicente-SP / Brasil

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Sáb, 5 de Maio 2012, 9:50

José Craveiro » Sáb Mai 05, 2012 12:48 am escreveu:Ora cá está:

Versão do Java verificada
Parabéns!
Você tem o Java recomendado instalado (Version 6 Update 32).

Entretanto o resultado deste comando:

sudo update-alternatives --config java


foi:
Código: Selecionar todos
Existem 2 escolhas para a alternativa java (disponibiliza /usr/bin/java).

  Selecção   Caminho                            Prioridade Estado
------------------------------------------------------------
  0            /usr/bin/gij-4.6                    1046      modo automático
  1            /usr/bin/gij-4.6                    1046      modo manual
* 2            /usr/lib/jvm/jre1.6.0_32/bin/java   1         modo manual

Pressione enter para manter a escolha actual[*], ou digite o número da selecção:


As opções 0 e 1 foi o que ficou após ter removido o jdk e o icedtea (provavelmente tipo serviços mínimos! :p ).

Haverá problema com a permanência deles ali, ainda que a escolhida seja a opção 2?


Boas José, tens a versão 64 bits ou 32 bits do Ubuntu instalado?

E seguiste o tutorial apropriado para a tua arquitectura?

É que durante o meu "post" anterior, estavas a utilizar comandos para a instalação do plugin em sistemas 32 bits!!

O resto do tutorial é igual, mas a criação do link simbólico é diferente!!
O comando para 64 bits será:

sudo ln -s /usr/lib/jvm/jre1.6.0_32/lib/amd64/libnpjp2.so


É que essas referências /usr/bin/gij-4.6, parecem ser relativas à instalação de uma versão do Java anterior.
Chegaste a ter instalado o Java Open JDK 7? Ou outro Java oficial?
Se sim, essas pastas são deles e convém remover, pois são de uma versão antiga e que não utilizarás.
Como tal, só estão a ocupar espaço! :D
Para tal, como já tens a última versão Java da Oracle a funcionar em pleno no teu PC:

sudo apt-get remove --purge openjdk*


e vês se remove alguma coisa. Não te preocupes que não irá mexer com a versão que acabaste de instalar!!

Caso não desinstale nada, abre o synaptic e procura lá por pacotes relacionados com o Java (esta última versão não irá aparecer, porque fizeste de forma manual e não existe nenhum pacote .deb para desinstalar!).
Remove tudo o que esteja relacionado com o Java, excepto o plugin do Libreoffice.
Por esta altura, abre o Firefox, vai aos extras e vê quantos plugins Java tens.
Se só tiveres 1, tudo bem, se aparecerem mais, é porque efectivamente tens outro Java instalado.

Para terminar, executa o comando:

sudo update-alternatives --config java


e vê se ainda te aparecem as tais opções.

Se for o caso, "posta" aqui o que se passou depois de tentares os passos acima descritos.
Resultado do comando no terminal e o que encontraste no synaptic relacionado com o Java.

Cumps.
Editado pela última vez por Miguel Fonseca em Sáb, 5 de Maio 2012, 11:28, em um total de 5 vezes.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Sáb, 5 de Maio 2012, 9:53

ron » Sáb Mai 05, 2012 1:19 am escreveu:
Miguel72 » Sex Mai 04, 2012 12:02 pm escreveu:
ron » Sex Mai 04, 2012 2:24 pm escreveu:HAHAHA Tudo bem, Miguel! :lol:

Mas acho que isso já vai de escolha do próprio utilizador. Imagina só: toda vez que você precisar instalar o Java numa máquina, fazer todo aquele procedimento? O PPA é bem mais fácil mesmo, fazer o quê?


Sim ron, o PPA é mais fácil!! Se dúvida nenhuma!!!

Mas leste o meu "post"?

E se o PPA não tiver sempre actualizado?!

Vais continuar com uma versão desactualizada do Java até quando?!

Se tens lido as últimas notícias, terás lido sem dúvida sobre os vários problemas de segurança pelos quais o Java tem passado!

Então, se o PPA se mantiver actualizado, tudo bem, eu também o farei.

Mas caso contrário, é sempre bom sabermos como fazer para instalá-lo manualmente e da forma mais simples, rápida e eficiente possível.

Cumps.


Li sim - e entendo isso. Mas enquanto tiver um ppa, estarei eu atualizando. O pessoal que fez este PPA atualiza sempre os ppas (utilizo alguns deles aqui) e sempre que sai algo estável. Então creio que vão atualizar tudo isto sim.

Cumps! =)


Boas ron, como eu disse, se for esse o caso e, assim que a Oracle disponibilizar os pacotes .bin para Linux, também eu utilizarei o PPA.

Mas nunca deixarei de visitar o site oficial para me certificar que estou actualizado.

Saindo uma versão nova, dependerá da disponibilidade de quem empacota os ficheiros no PPA de manter SEMPRE a versão actualizada.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Sáb, 5 de Maio 2012, 14:59

Olá MIguel,

Tenho o Ubuntu 32 bits, portanto tudo indica que fiz corretamente!

Quanto à instalação de um Java anterior, sim tive o conteúdo associado ao java do ubuntu-restricted-extras com jdk e icedtea, que entretanto removi (pelos vistos não tudo) e ficou isto que me parecia ser algum resto que ficou daquela instalação.

Executando este comando:
sudo apt-get remove --purge openjdk*

Havia 1 pacote por remover:
Código: Selecionar todos
openjdk-6-jre-headless*
que já foi removido!

No Firefox tenho apenas o Java(TM) Plug-in 1.6.0_32

No Synaptic: procurando por jdk e icedtea, nada encontrei com visto de instalação, procurando por java, encontrei:
gcj-4.6-jre-headless que tem um diretório /usr/bin/gij-4.6
gcj-4.6-jre-lib

Parece mais evidente o primeiro, mas tenho dúvidas...

Ou seja, dentro da pasta jvm tenho o seguinte:
java-1.5.0-gcj (pasta)
java-1.5.0-gcj-4.6 (pasta)
java-gcj (pasta)
java-gcj-4.6 (pasta)
jre1.6.0_32 (pasta)
jre-6u32-linux-i586.bin (o atual bin)
.java-gcj-4.6.jinfo (ficheiro de texto)

Dizes para remover tudo o que se relacione com o java, mas será que nada do novo java que agora instalei estará no Synaptic?

O resultado do: sudo update-alternatives --config java - foi o mesmo! :|



Atualizando aqui o post:
Entretanto, como ainda não tinha instalado este Java no fixo, comecei por remover/purgar o jdk instalado pelo restricted-extras e o resultado, tal como ocorreu com o portátil e daí aparecer o que chamava de "restos" anteriores, foi este:
Spoiler:
Código: Selecionar todos
~$ sudo apt-get remove --purge openjdk*
[sudo] password for jose:
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
Note, a seleccionar 'openjdk-6-demo' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-jre-headless' para a expressão regular 'openjdk*'
Note, a seleccionar 'uwsgi-plugin-jwsgi-openjdk-6' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-jre' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-source' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-dbg' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk7-jdk' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-doc' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-jre-zero' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-demo' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-jre-headless' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-jdk' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-jre' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-jre-lib' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-jre-zero' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-dbg' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-doc' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-jdk' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-jre' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-6-source' para a expressão regular 'openjdk*'
Note, a seleccionar 'openjdk-7-jre-lib' para a expressão regular 'openjdk*'
Note, a seleccionar 'uwsgi-plugin-jvm-openjdk-6' para a expressão regular 'openjdk*'
O pacote openjdk-6-dbg não está instalado, por isso não será removido
O pacote openjdk-6-demo não está instalado, por isso não será removido
O pacote openjdk-6-doc não está instalado, por isso não será removido
O pacote openjdk-6-jdk não está instalado, por isso não será removido
O pacote openjdk-6-source não está instalado, por isso não será removido
O pacote openjdk-6-jre-zero não está instalado, por isso não será removido
O pacote openjdk-7-dbg não está instalado, por isso não será removido
O pacote openjdk-7-demo não está instalado, por isso não será removido
O pacote openjdk-7-doc não está instalado, por isso não será removido
O pacote openjdk-7-jdk não está instalado, por isso não será removido
O pacote openjdk-7-jre não está instalado, por isso não será removido
O pacote openjdk-7-jre-headless não está instalado, por isso não será removido
O pacote openjdk-7-jre-lib não está instalado, por isso não será removido
O pacote openjdk-7-jre-zero não está instalado, por isso não será removido
O pacote openjdk-7-source não está instalado, por isso não será removido
O pacote uwsgi-plugin-jvm-openjdk-6 não está instalado, por isso não será removido
O pacote uwsgi-plugin-jwsgi-openjdk-6 não está instalado, por isso não será removido
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  language-pack-zh-hans kde-l10n-ptbr kde-l10n-pt language-pack-kde-en
  language-pack-kde-pt language-pack-kde-pt-base language-pack-kde-zh-hans
  language-pack-kde-en-base kde-l10n-engb libreoffice-filter-mobiledev
  kde-l10n-zhcn ttf-sil-gentium-basic language-pack-zh-hans-base
  firefox-locale-zh-hans language-pack-kde-zh-hans-base
Utilize 'apt-get autoremove' para os remover.
Os seguintes pacotes extra serão instalados:
  gcj-4.6-base gcj-4.6-jre gcj-4.6-jre-headless gcj-4.6-jre-lib gcj-jre
  gcj-jre-headless libgcj-common libgcj12 libgcj12-awt
Pacotes sugeridos:
  fastjar gcj-4.6-jdk gcj-jdk libgcj12-dbg
Serão REMOVIDOS os seguintes pacotes:
  ca-certificates-java* default-jre* default-jre-headless*
  icedtea-6-jre-cacao* icedtea-6-jre-jamvm* icedtea-netx* libhsqldb-java*
  libreoffice* libreoffice-base* openjdk-6-jre* openjdk-6-jre-headless*
  openjdk-6-jre-lib*
Serão instalados os seguintes NOVOS pacotes:
  gcj-4.6-base gcj-4.6-jre gcj-4.6-jre-headless gcj-4.6-jre-lib gcj-jre
  gcj-jre-headless libgcj-common libgcj12 libgcj12-awt
0 pacotes actualizados, 9 pacotes novos instalados, 12 a remover e 0 não actualizados.
É necessário obter 22,1 MB de arquivos.
Após esta operação, será libertado 52,0 MB de espaço em disco.
Deseja continuar [Y/n]? Y
Obter:1 http://pt.archive.ubuntu.com/ubuntu/ precise/main libgcj-common all 1:4.6.3-1ubuntu5 [127 kB]
Obter:2 http://pt.archive.ubuntu.com/ubuntu/ precise/main gcj-4.6-base i386 4.6.3-1ubuntu2 [11,3 kB]
Obter:3 http://pt.archive.ubuntu.com/ubuntu/ precise/main libgcj12 i386 4.6.3-1ubuntu2 [11,4 MB]
Obter:4 http://pt.archive.ubuntu.com/ubuntu/ precise/main gcj-4.6-jre-headless i386 4.6.3-1ubuntu2 [60,0 kB]
Obter:5 http://pt.archive.ubuntu.com/ubuntu/ precise/main gcj-jre-headless i386 4:4.6.3-1ubuntu5 [1558 B]
Obter:6 http://pt.archive.ubuntu.com/ubuntu/ precise/main libgcj12-awt i386 4.6.3-1ubuntu2 [81,9 kB]
Obter:7 http://pt.archive.ubuntu.com/ubuntu/ precise/main gcj-4.6-jre i386 4.6.3-1ubuntu2 [1058 B]
Obter:8 http://pt.archive.ubuntu.com/ubuntu/ precise/main gcj-jre i386 4:4.6.3-1ubuntu5 [1062 B]
Obter:9 http://pt.archive.ubuntu.com/ubuntu/ precise/main gcj-4.6-jre-lib all 4.6.3-1ubuntu2 [10,5 MB]
Obtidos 22,1 MB em 18s (1211 kB/s)                                             
Selecionando pacote libgcj-common previamente não selecionado.
(A ler a base de dados ... 243457 ficheiros e directórios actualmente instalados.)
A descompactar libgcj-common (desde .../libgcj-common_1%3a4.6.3-1ubuntu5_all.deb) ...
Selecionando pacote gcj-4.6-base previamente não selecionado.
A descompactar gcj-4.6-base (desde .../gcj-4.6-base_4.6.3-1ubuntu2_i386.deb) ...
Selecionando pacote libgcj12 previamente não selecionado.
A descompactar libgcj12 (desde .../libgcj12_4.6.3-1ubuntu2_i386.deb) ...
Selecionando pacote gcj-4.6-jre-headless previamente não selecionado.
A descompactar gcj-4.6-jre-headless (desde .../gcj-4.6-jre-headless_4.6.3-1ubuntu2_i386.deb) ...
Selecionando pacote gcj-jre-headless previamente não selecionado.
A descompactar gcj-jre-headless (desde .../gcj-jre-headless_4%3a4.6.3-1ubuntu5_i386.deb) ...
A processar 'triggers' para man-db ...
A instalar libgcj-common (1:4.6.3-1ubuntu5) ...
A instalar gcj-4.6-base (4.6.3-1ubuntu2) ...
A instalar libgcj12 (4.6.3-1ubuntu2) ...
A instalar gcj-4.6-jre-headless (4.6.3-1ubuntu2) ...
A instalar gcj-jre-headless (4:4.6.3-1ubuntu5) ...
A processar 'triggers' para libc-bin ...
ldconfig deferred processing now taking place
Selecionando pacote libgcj12-awt previamente não selecionado.
(A ler a base de dados ... 243583 ficheiros e directórios actualmente instalados.)
A descompactar libgcj12-awt (desde .../libgcj12-awt_4.6.3-1ubuntu2_i386.deb) ...
Selecionando pacote gcj-4.6-jre previamente não selecionado.
A descompactar gcj-4.6-jre (desde .../gcj-4.6-jre_4.6.3-1ubuntu2_i386.deb) ...
Selecionando pacote gcj-jre previamente não selecionado.
A descompactar gcj-jre (desde .../gcj-jre_4%3a4.6.3-1ubuntu5_i386.deb) ...
A instalar libgcj12-awt (4.6.3-1ubuntu2) ...
A instalar gcj-4.6-jre (4.6.3-1ubuntu2) ...
A instalar gcj-jre (4:4.6.3-1ubuntu5) ...
(A ler a base de dados ... 243589 ficheiros e directórios actualmente instalados.)
A remover libreoffice ...
A remover libreoffice-base ...
A purgar os ficheiros de configuração para libreoffice-base ...
A remover icedtea-netx ...
update-alternatives: a usar /usr/lib/jvm/java-7-openjdk-i386/jre/bin/javaws para disponibilizar /usr/bin/javaws (javaws) em modo automático.
A remover default-jre ...
A remover openjdk-6-jre ...
A remover icedtea-6-jre-jamvm ...
A remover icedtea-6-jre-cacao ...
A remover libhsqldb-java ...
A remover default-jre-headless ...
A remover openjdk-6-jre-lib ...
A remover openjdk-6-jre-headless ...
update-alternatives: a usar /usr/bin/gij-4.6 para disponibilizar /usr/bin/java (java) em modo automático.
update-alternatives: a usar /usr/bin/gkeytool-4.6 para disponibilizar /usr/bin/keytool (keytool) em modo automático.
update-alternatives: a usar /usr/bin/grmid-4.6 para disponibilizar /usr/bin/rmid (rmid) em modo automático.
update-alternatives: a usar /usr/bin/grmiregistry-4.6 para disponibilizar /usr/bin/rmiregistry (rmiregistry) em modo automático.
update-alternatives: a usar /usr/bin/gorbd-4.6 para disponibilizar /usr/bin/orbd (orbd) em modo automático.
A purgar os ficheiros de configuração para openjdk-6-jre-headless ...
A remover ca-certificates-java ...
A purgar os ficheiros de configuração para ca-certificates-java ...
A processar 'triggers' para man-db ...
A processar 'triggers' para desktop-file-utils ...
A processar 'triggers' para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
A processar 'triggers' para gnome-menus ...
A processar 'triggers' para hicolor-icon-theme ...
Selecionando pacote gcj-4.6-jre-lib previamente não selecionado.
(A ler a base de dados ... 243188 ficheiros e directórios actualmente instalados.)
A descompactar gcj-4.6-jre-lib (desde .../gcj-4.6-jre-lib_4.6.3-1ubuntu2_all.deb) ...
A instalar gcj-4.6-jre-lib (4.6.3-1ubuntu2) ...


Isto quer-me parecer que ao remover o jdk, o "gcj-4.6-jre-lib (4.6.3-1ubuntu2) ..." assume o poder! :|
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Sáb, 5 de Maio 2012, 18:50

Boas José, desinstala no synaptic esse "segundo" Java, pois não precisas dele.

O "poder" foi assumido, por tua ordem pelo Java 6 update 32 que instalaste manualmente!

E de certeza que desta versão que instalaste não existe NADA no synaptic!

No synaptic só constam pacotes instalados através do processo .deb. Que é utilizado pela Canonical, Parceiros e Repositórios de Terceiros para instalar o que quer que seja nos nossos sistemas!

Conforme podes confirmar no terminal quando utilizas o comando "sudo apt-get install!, vais reparar que é sempre descarregado o programa com extensão .deb.

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Sáb, 5 de Maio 2012, 20:17

Bom, posso não precisar daqueles elementos do "Java anterior" e até ficar confiante em como o que consta no Synaptic acerca do mesmo, simplesmente não esteja lá; agora o que reparei à medida que ia colocando o visto para desinstalação nos itens no Synaptic, é que para além de um ou dois obviamente articulados ao LibreOffice, haviam outros que embora não fossem óbvios, ao colocar o visto, surgiu o alerta de remoção da própria suite.

Resumindo, aqueles que não me alertaram da remoção do LibreOffice e ou outros, removi-os. Um dado curioso é que verifiquei dois que removeriam os componentes que se pretendem, só que automaticamente se instalariam de novo o jdk e o icedtea!
Portanto, removi o que achei que podia remover, o resto deixei como estava; porque o mais provável acontecer era que se a remoção de todos me desinstalariam o LibreOffice, ao voltar a instalar esta suite, voltava tudo ao mesmo!
Se o Java que ultimamente instalei é soberano em relação ao resto que lá existe, em princípio não haverá problemas, ou estou assim tão errado? :|
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Sáb, 5 de Maio 2012, 23:12

Boas José, não estás errado de maneira nenhuma!!

O que acontece é que a parte do Java com que ficaste no sistema que não pertence ao update 32, são pacotes e bibliotecas que fazem parte da suite Libreoffice.
E tal como eu referi, deverias apagar tudo o que tivesse relacionado com o Java utilizando o Synaptic excepto o que estaria agregado do Libreoffice.

Ainda não me confirmaste se tens arquitectura de 32 ou 64 bits.

E mesmo depois de desinstalares os pacotes, quando executas o comando:

sudo update-alternatives --config java


ainda te aparece o mesmo?

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Dom, 6 de Maio 2012, 0:09

Miguel72 » Sáb Mai 05, 2012 11:12 pm escreveu:
Ainda não me confirmaste se tens arquitectura de 32 ou 64 bits.

E mesmo depois de desinstalares os pacotes, quando executas o comando:

sudo update-alternatives --config java


ainda te aparece o mesmo?

Cumps.


Ok, esqueci de referir a parte da arquitetura (portanto o hardware), esta aceita as duas versões, mas prefiro usar o ubuntu a 32 bits.

Acerca dos pacotes (esta já tinha respondido :p ), mas aqui vai agora em pormenores:
Código: Selecionar todos
Existem 2 escolhas para a alternativa java (disponibiliza /usr/bin/java).

  Selecção   Caminho                            Prioridade Estado
------------------------------------------------------------
  0            /usr/bin/gij-4.6                    1046      modo automático
  1            /usr/bin/gij-4.6                    1046      modo manual
* 2            /usr/lib/jvm/jre1.6.0_32/bin/java   1         modo manual


Ou seja, o tal pacote que ao que tudo parece indicar, integrado no LibreOffice.
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor Miguel Fonseca » Dom, 6 de Maio 2012, 11:53

Boas José, isto é muito estranho!

Também eu uso o Ubuntu 12.04 de 32 bits, tenho o Libreoffice instalado e não me aprecem esses pacotes.

No meu caso:

Código: Selecionar todos
miguelfonseca@miguelfonseca-PC:~$ sudo update-alternatives --config java
[sudo] password for miguelfonseca:
Há 1 escolha para a alternativa java (disponibiliza /usr/bin/java).

  Selecção   Caminho                            Prioridade Estado
------------------------------------------------------------
  0            /usr/lib/jvm/jre1.6.0_32/bin/java   1         modo automático
* 1            /usr/lib/jvm/jre1.6.0_32/bin/java   1         modo manual

Pressione enter para manter a escolha actual[*], ou digite o número da selecção:
miguelfonseca@miguelfonseca-PC:~$


Diz-me uma coisa, instalaste algumas bibliotecas adicionais para o GCC?

Ou alguns "add-ons" extras para o Libreoffice?

Que Javas instalaste anteriormente e que processos utilizaste para a sua instalação?

Cumps.
It is only in Love and Murder, that we still remain sincere! - Friedrich Durrenmatt
Avatar do usuário
Miguel Fonseca
Bleeding-edge Helper
 
Mensagens: 2512
Registrado em: 10 Junho, 2011

Re: Ubuntu 12.04 Precise Pangolin – Resolvendo problema com

Mensagempor José Craveiro » Dom, 6 de Maio 2012, 13:00

Pois, eu calculei que tivesses esta reação porque já tainha reparado que tal não tinha sucedido contigo, mas que dizer para além do que já referi antes, ou seja, o que quer que tenha sido instalado anteriormente tem por fonte ou o próprio LibreOffice ou então o pacote ubuntu-restricted-extras? Sinceramente não sei! :roll:

Tens instalado o pacote Medibuntu não é? Quiçá esteja aí a resposta!
Se sim, é provável que este pacote não descarregue o que o restricted-extras descarregou, talvez um elemento ou conjunto de elementos ligados à funcionalidade do Java e que estabelece a condição que mostrei, ou seja, se desinstalar o que aqui estamos a considerar a mais, automaticamente gera nova estrutura de jdk e icedtea; isto colocando a culpa neste pacote, obviamente. Se sim, paciência, não me dei bem como o Medibuntu, estavam quase constantemente a surgir avisos de certificados não satisfeitos e cansei; como até à data não tive problemas com o ubuntu-restricted-extras, decidi-me por ele.
Acho que o melhor é deixar estar como está e evitar males maiores, embora não ache neste momento que esteja diante de um mal propriamente dito, o sistema funciona, o Java realmente funciona e neste âmbito é o que realmente importa.
Desde a 1ª vez que usei um computador pessoal até agora (já lá vão uns 8 anos), ainda que com muitas aventuras e insistências pelo caminho, as quais considero uma aprendizagem, gradualmente fui-me habituando à ideia de que nem tudo conseguimos resolver no momento e nem tudo o que nos incomoda podemos imediatamente eliminar a troco de pagar o preço das coisas simplesmente não funcionarem..., ora, isto não significa que me resignei ao facto de deixar as coisas como estão indefinidamente, mas sim que se não consigo hoje posso conseguir amanhã! ;)
Avatar do usuário
José Craveiro
 
Mensagens: 996
Registrado em: 11 Junho, 2011
Localização: Coimbra

AnteriorPróximo

Tópicos Similares:

Voltar para Publique artigos no Blog Ubuntued!

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes

cron